Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

SUPERCALENDAR EVENTS ERROR.

By
dbvieira
on 9/26/14, 5:58 AM 725 views

When displaying the events on supercalendar with main speaker filled i get the error when i press the generate calendar

Error


The 'User' field of record "xxxxxx" (event.event) does not refer to res.users

 

Any ideas?


Regards


David

rollback (http://en.wikipedia.org/wiki/Rollback_%28data_management%29)

Med Said BARA
on 9/26/14, 6:29 PM
0
IT Libertas
On 7/3/16, 8:56 AM

It seems, the app https://apps.odoo.com/apps/modules/9.0/joint_calendar/ may suit some of your requirements

0

Med Said BARA

--Med Said BARA--
2664
| 5 5 7
Algeria
--Med Said BARA--
Med Said BARA
On 9/26/14, 6:15 AM

Use PgAdmin and access the table event_event of your DB to see which user is causing this error (maybe a deleted user!), cause there is a constraint on the user_id column in relation with the res_users table.
 

No it seems everythig is ok The only thing I made was in PgAdmin I set to true the some user as Employee and Speaker so they could appear on the Speakers List...

dbvieira
on 9/26/14, 7:32 AM

This is your mistake by doing so (using pgadmin to directly modify some records), you bypass some mechanisms, and you break relationships between tables (constraints). Undo your changes, create the employees as usual (from HR app) and link them to users ...

Med Said BARA
on 9/26/14, 8:08 AM

...i tried opening the users, opening the employees...but when going the events the collumn speaker is empty.

dbvieira
on 9/26/14, 2:30 PM

If you have not yet created the Main Speaker (in this case It's normal that the column is empty), just add it (Create and Edit).

Med Said BARA
on 9/27/14, 9:05 AM

Does not work!. I created a new user but I always get the same error when assigning Main Speaker to User Field under the configurators on the supercalendar

dbvieira
on 10/7/14, 6:53 AM

Does not work!. I created a new user but I always get the same error when assigning Main Speaker to User Field under the configurators on the supercalendar

dbvieira
on 10/7/14, 6:53 AM
0
dbvieira
On 10/6/14, 1:32 PM

Thanks Med. What I did was:

Open the company, untick the last blank option on each contact. Saved the "Company" and ticked tham again, and resaved the company.

This field is blank and misses the "speaker" label.

regards

David

 

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 9/26/14, 5:58 AM
Seen: 725 times
Last updated: 7/3/16, 8:56 AM