Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

[SOLVED][8.0] Runbot permissions in Docker container

By
Peter Alabaster
on 10/15/16, 5:48 AM 234 views

Hi, I'm trying to get a docker container up and running runbot but am having some permissions issues.

I took the base Odoo 8 image and am installing the extra pip dep needed:

matplotlib

The image is building fine, and i'm starting the container up with a mountpoint (from docker-compose.yml):

volumes:
  - ./addons:/mnt/extra-addons

In my local `./addons` folder resides the module `runbot` from \odoo-extra:8.0

Adding a public repo to the odoo instance and cilcking `Update` results in:

OSError: [Errno 2] No such file or directory.

I ran the following:

chown -R odoo.odoo /mnt/extra-addons/runbot/static/

from inside the container and still got the error.
Thus - I double checked which user the particular file was running as:

(Pdb) print "Effective user is [%s]" % (getpass.getuser());
Effective user is [odoo]

I even tried

chmod -R 777 /mnt/extra-addons/runbot/static/

and still can't get it to work.

Am I missing something?




EDIT:

Solved by adding git as a system dependency to my Dockerfile. Oops

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 10/15/16, 5:48 AM
Seen: 234 times
Last updated: 10/17/16, 5:54 AM