Odoo Help

0

Server in debug-mode stops on assertion - how to continue it?

By
Gregor Heger
on 3/13/14, 2:01 PM 1,562 views

Hi,

I just accomplished to debug the server within eclipse on windows. But now I experience some problem: If the server trips on some assertion, the server freezes itself. I'm not able to continue it by Eclipse, for example by clicking on run or something.

The usual behavior before debugging was, that the openerp web pops up an error page, explaining the assertion. By clicking on okay, the server continues. How can I enable this behavior in debug mode? I tried to add "assert_exit_level = critical" within the openerp-server.conf file, but it doesn't help. Does someone have an idea?

0
Gregor Heger
On 3/13/14, 4:36 PM

Okay, I also found this one out. Within the openerp-server.conf I had to write: assert_exit_level = notset On assertion, the previous box is popping up and the server is not freezing. WRONG!!! Sorry, setting asser_exit_level to notset DIDN'T SOLVE the problem (I forgot that I've set debug_mode to false again - but it should be true)

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

0 follower(s)

Stats

Asked: 3/13/14, 2:01 PM
Seen: 1562 times
Last updated: 3/16/15, 8:10 AM