Odoo Help


Server Action mail problem

Viktor léhner
on 6/1/14, 11:46 AM 1,128 views

Dear Users!

My issue is:

First i generate an automatic operation , this operation start a server action (send mail). Everythin ok, but:

After when a change the content of the email, the changes does not appear the email message!

What is the solutution?

/if i delet the server action and create a new is working, but this way is not convinient/




Are you doing that on a xml file? Upgrade your module after you make your changes in order they take effect!

Luis Filipe Castanheira
on 6/1/14, 12:53 PM

Hi, no i am doing on the administration /back end/ site. Thanks your suggestion, i will try.

Viktor léhner
on 6/1/14, 1:31 PM

Dear Luis! Where is the location of the XML file?

Viktor léhner
on 6/1/14, 3:20 PM

I asked about the XML file because you might be implementing a custom module and create action servers on XML, and you might be forgetting to upgrade your module after changing the XML. But since you are doing it on OpenERP's technical settings, it should be working all right. So I don't know what is the problem.

Luis Filipe Castanheira
on 6/2/14, 4:17 AM
Viktor léhner
On 6/2/14, 7:15 AM

I will try to describe the problem simplier:

1. i have a server action ( send email)

2 i modify the email body content /add new line etc./

3 i save the server action

4 i check the changes happend, it is ok

5 the changes is do not apper in the incoming mail

Viktor léhner
On 6/3/14, 4:24 AM

Finally i found a bug: Translated Server Action (send mail) field.

The probem is the translated field. If i copy to the source field, is working correctly!

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

2 follower(s)


Asked: 6/1/14, 11:46 AM
Seen: 1128 times
Last updated: 3/16/15, 8:10 AM