Odoo Help

0

Qweb report is taking long time to print and getting timeout

By
Burhan Vakharia
on 6/13/18, 7:26 AM 351 views

Hello,

I have my Odoo running on Apache port 80 with SSL and Odoo is running as an WSGI Application.

I have wkthmltopdf library properly installed with correct supported version 0.12.1 (with patched qt)

Whenever I try to print any qweb report on my server, it starts loading and then finally it timeout. 

I tried to search for this issue and I found a solution to change the web_base_url in system parameter to 127.0.0.1.

When I change it to 127.0.0.1, I am able to print the report, but then odoo appends 127.0.0.1 in all the system generated urls like Signup form or change password urls.


By default Odoo is setting my server url as 'http' in web_base_url. I have SSL configured and I am not sure if this is the issue. I tried to change 'http' to 'https' in web_base_url but no luck.

I am unable to understand why this it is happening and how I can fix it. Can you please help me?

Thank you in advance.


I found this GitHub issue linked to the same problem

https://github.com/odoo/odoo/issues/24173

But I am unable to understand what exact steps I need to follow to fix this.

Burhan Vakharia
on 6/13/18, 7:35 AM
1

Ermin Trevisan

--Ermin Trevisan--
8433
| 6 5 7
Walchwil, Switzerland
--Ermin Trevisan--


Ermin Trevisan
On 6/14/18, 8:17 AM

You should set the report.url parameter, not the web.base.url.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 6/13/18, 7:26 AM
Seen: 351 times
Last updated: 7/17/18, 12:45 AM