Odoo Help

0

Problem with starting OpenERP 7 on Ubuntu 12 after installation

By
ITS Jamaica
on 8/21/13, 6:36 PM 1,924 views

Hi,

I am new user to Open ERP and Ubuntu I have followed the step by step installation instructions on how to do get the server up and running. I am getting an error code when I try to start up OpenERP that a port is already in use when I kill the process and try to run the command again I still get the same error. Please see below error that I am getting from the server

 openerp@itsja-PowerEdge-T105:~$ /opt/openerp/server/openerp-server
2013-08-21 20:16:12,179 30116 INFO ? openerp: OpenERP version 7.0-20130818-231031
2013-08-21 20:16:12,179 30116 INFO ? openerp: addons paths: /opt/openerp/server/openerp/addons
2013-08-21 20:16:12,179 30116 INFO ? openerp: database hostname: localhost
2013-08-21 20:16:12,179 30116 INFO ? openerp: database port: 5432
2013-08-21 20:16:12,179 30116 INFO ? openerp: database user: openerp
2013-08-21 20:16:12,730 30116 INFO ? openerp.addons.google_docs.google_docs: GData lib version `%s GData-Python/2.0.18` detected
Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib/python2.7/threading.py", line 551, in __bootstrap_inner
    self.run()
  File "/usr/lib/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/opt/openerp/server/openerp/service/wsgi_server.py", line 436, in serve
    httpd = werkzeug.serving.make_server(interface, port, application, threaded=True)
  File "/usr/lib/python2.7/dist-packages/werkzeug/serving.py", line 399, in make_server
    passthrough_errors, ssl_context)
  File "/usr/lib/python2.7/dist-packages/werkzeug/serving.py", line 331, in __init__
    HTTPServer.__init__(self, (host, int(port)), handler)
  File "/usr/lib/python2.7/SocketServer.py", line 408, in __init__
    self.server_bind()
  File "/usr/lib/python2.7/BaseHTTPServer.py", line 108, in server_bind
    SocketServer.TCPServer.server_bind(self)
  File "/usr/lib/python2.7/SocketServer.py", line 419, in server_bind
    self.socket.bind(self.server_address)
  File "/usr/lib/python2.7/socket.py", line 224, in meth
    return getattr(self._sock,name)(*args)
error: [Errno 98] Address already in use

2013-08-21 20:16:13,227 30116 INFO ? openerp: OpenERP server is running, waiting for connections...
0
Grover Menacho
On 8/21/13, 11:22 PM

On your configuration file change the port 8069 to another one. That works for me because I am running 2 versions of OpenERP

0

look at the process running. If there are 2 instances of openERP they could be messing each other up.

try stopping the server - type ps aux | grep openerp to confirm you stopped the server, then start the server again.

If that doesn't solve the problem you will have to figure out what other program is using that port and shut it down/ get it to use a different port.

Use netstat -tlnp | grep 8069 to try to figure out what program is using that port.

0
Borni DHIFI
On 8/21/13, 7:03 PM

Hi,

Address already in use.

so kill all process openerp and restart server openerp and must work.

I killed the server and restarted and samething itsja@itsja-PowerEdge-T105:~$ ps ax | grep openerp-server 10068 ? Sl 0:21 python /opt/openerp/server/openerp-server 10214 ? Sl 0:01 python /opt/openerp/server/openerp-server 10914 ? Sl 0:04 python /opt/openerp/server/openerp-server 12733 ? Sl 0:02 python /opt/openerp/server/openerp-server 15465 ? SNl 0:02 /usr/bin/python /usr/bin/openerp-server --config=/etc/openerp/openerp-server.conf --logfile=/var/log/openerp/openerp-server.log 15668 ? Sl 0:02 python /opt/openerp/server/openerp-

ITS Jamaica
on 8/21/13, 7:09 PM

Are you sure you are killing the processes - what you pasted looks like you have SIX server processes running.

Bista Solutions US, Ray Carnes
on 8/21/13, 7:20 PM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 8/21/13, 6:36 PM
Seen: 1924 times
Last updated: 3/16/15, 8:10 AM