Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

posgresql fatal error: password authentication failed for user "opengp"

By
Titus
on 5/29/13, 5:27 AM 7,084 views

I have installed open-ERP7 all in one.

I uninstalled it and when i tried installing again I have been having issues with postgresql database.

When I open openERP I get a server error; "OperationalError: FATAL: password authentication failed for user "openpg"

When I access my postgresql server through pgAdmin III I get the same error: "password authentication failed for user "opengp""

I have tried to install and install openERP as well as postgresql db but I'm not getting a solution. any help.

I am using windows 7 64 bit

what password did you tried

sridhar
on 5/29/13, 6:22 AM

Name: lohalhost host: localhost port: 5432 Maintainance DB: postgres Username: openerp password: openpgpwd server information.

sridhar
on 5/29/13, 6:29 AM
0
Titus
On 5/30/13, 9:47 AM

I was able to resolve my problem. After unistalling openERP and postgresql I removed all postgres related keys from windows registry.

I was able to install openerp again.

0
sridhar
On 5/30/13, 10:27 AM

Try this way Name: localhost host: localhost port: 5432 Maintainance DB: postgres Username: openerp password: openpgpwd server information.

0
Amit Parik (amp)
On 5/29/13, 7:28 AM

Hello Titus,

The problem is we can't completely remove the postgres on windows.That's why this problem is occurs.

I think when you was install all in one you didn't check the check box for postgres or you was install postgres first then try to run OpenERP all in one.

What I suggest open the control panel and remove the all packages of postgres then after try to run setup.exe with check that postgres checkbox.

Hope this will help.

Thank you!

Thankyou Amit. I unistalled both the postgresql and the openerp. But now when I try installing the openerp on the window to select the components to install the option for postgresql is inactive (I cant select). When I install postgres on its own I get three servers, one has openpg as the owner but does not take openpgpwd as the password. I have been trying for the last four days. any suggestions?

Titus
on 5/30/13, 3:36 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 5/29/13, 5:27 AM
Seen: 7084 times
Last updated: 3/16/15, 8:10 AM