Odoo Help

3

ParseError: "decoder jpeg not available" while parsing in odoo

By
Piyush Suva
on 10/11/14, 3:42 AM 2,382 views

When I createing new database in odoo at that time it gives the error of  "decoder jpeg not available"

I also tried :

     pip uninstall PIL    

     pip install pillow

sudo apt-get install python-imaging

 

1
Atul Arvind
On 10/6/16, 4:24 PM

libjpeg8-dev is required to be able to process jpegs with pillow (or PIL) for ubuntu 14.04 and higher, so you need to install it and then recompile pillow. Install 

sudo apt-get install libjpeg8-dev

and try to reinstall the pillow 

pip install --no-cache-dir -I pillow

Hope this helps!

3
Ben Bernard
On 10/11/14, 4:40 AM

Make sure you have libjpeg and libjpeg-dev installed. After this try to reinstall pillow module. The output should contain

--- JPEG support available

If the output already contains that string and the error still persist check this answer: https://stackoverflow.com/questions/22409140/pillow-recognizes-jpeg-encoder-on-install-but-not-use

Thank you Ben.

Piyush Suva
on 10/13/14, 5:59 AM
1
Nirav Jani
On 10/15/14, 3:31 AM

Yes Mr. Ben is right, It will work so that please follow him.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 10/11/14, 3:42 AM
Seen: 2382 times
Last updated: 10/6/16, 4:25 PM