Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

OperationalError: no connection to the server

By
Jeff Truthan
on 3/1/13, 4:27 PM 1,605 views

This is a highly relevant question, using 6.1 and trying to migrate to 7.0. I have submitted a database for migration. Six weeks later, get back something that might work (passwords were not migrated, nor state_id codes). I have submitted a ticket to migration but heard nothing back. Note in the migration file observed that I have more than 10 users (which exceeds my "support" level). Unfortunately, OpenERP counts users rather than folks who have actually logged in, which is only 5. Trying to use my existing 6.1 database in the existing application, I have a number of different databases, any one of which I can log into just fine. So I know that my database connection is fine - otherwise it could not show me any of the available database names. However, when I select the database that I sent for migration and try to login to it, I get the following message:

Your version of OpenERP is unsupported. Support & maintenance services are available here: OpenERP Entreprise.

OpenERP Server Error

Client Traceback (most recent call last):
  File "/home/skilltran/openerp-6.1/openerp-web/addons/web/common/http.py", line 180, in dispatch
    response["result"] = method(controller, self, **self.params)
  File "/home/skilltran/openerp-6.1/openerp-web/addons/web/controllers/main.py", line 498, in authenticate
    req.session.authenticate(db, login, password, env)
  File "/home/skilltran/openerp-6.1/openerp-web/addons/web/common/session.py", line 73, in authenticate
    uid = self.proxy('common').authenticate(db, login, password, env)
  File "/home/skilltran/openerp-6.1/openerp-web/addons/web/common/openerplib/main.py", line 117, in proxy
    result = self.connector.send(self.service_name, method, *args)
  File "/home/skilltran/openerp-6.1/openerp-web/addons/web/common/http.py", line 608, in send
    raise xmlrpclib.Fault(openerp.tools.exception_to_unicode(e), formatted_info)


Server Traceback (most recent call last):
  File "/home/skilltran/openerp-6.1/openerp-web/addons/web/common/http.py", line 593, in send
    return openerp.netsvc.dispatch_rpc(service_name, method, args)
  File "/home/skilltran/openerp-6.1/server/openerp/netsvc.py", line 360, in dispatch_rpc
    result = ExportService.getService(service_name).dispatch(method, params)
  File "/home/skilltran/openerp-6.1/server/openerp/service/web_services.py", line 397, in dispatch
    return fn(*params)
  File "/home/skilltran/openerp-6.1/server/openerp/service/web_services.py", line 409, in exp_authenticate
    return res_users.authenticate(db, login, password, user_agent_env)
  File "/home/skilltran/openerp-6.1/server/openerp/addons/base/res/res_users.py", line 459, in authenticate
    uid = self.login(db, login, password)
  File "/home/skilltran/openerp-6.1/server/openerp/addons/base/res/res_users.py", line 478, in login
    cr = pooler.get_db(db).cursor()
  File "/home/skilltran/openerp-6.1/server/openerp/sql_db.py", line 465, in cursor
    return Cursor(self._pool, self.dbname, serialized=serialized)
  File "/home/skilltran/openerp-6.1/server/openerp/sql_db.py", line 180, in __init__
    self.autocommit(False)
  File "/home/skilltran/openerp-6.1/server/openerp/sql_db.py", line 152, in wrapper
    return f(self, *args, **kwargs)
  File "/home/skilltran/openerp-6.1/server/openerp/sql_db.py", line 325, in autocommit
    self._cnx.set_isolation_level(isolation_level)
OperationalError: no connection to the server

Because I can see in the dropdown box and login to other databases that were not submitted for migration, this makes me wonder if somehow OpenERP is able to "blackball" this database on my own servers, and prevent me from using my own data! Using a database tool called Navicat (a multi-database tool equivalent to pgAdmin), I have rebuilt indexes and done a full vacuum on this database. Still not able to login as any user to this data file. This is the original data file that worked fine ... yesterday and before, but not today.

Would you please format your question's exception logs into a readable format using the <blockquote> button? Thanks.

Martin
on 3/1/13, 9:36 PM

It took a <blockquote> and a <pre> tag to do this.

Jeff Truthan
on 3/2/13, 9:49 PM

I am using 2 servers, one cloud server for the OERP application, the other a dedicated database for the data. I rebooted the cloud server and am now able to login to the troublesome database. I am completely baffled about how that could work, since I had been able to login to the other databases but just not the one I had migrated. Odd ... further explanation would be helpful.

Jeff Truthan
on 3/3/13, 6:46 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 3/1/13, 4:27 PM
Seen: 1605 times
Last updated: 3/16/15, 8:10 AM