Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

OpenERP7 (windows) : Server error message

By
Sales
on 5/14/13, 11:04 AM 3,299 views

Hello,

I would like test OpenERP 7. I tried this morning to install openerp all in one on my windows 7 station. I let by default informations regarding postgres db.

But it does not work. When i try to launch OpenERP, a webpage opens (localhost:8069) with this following error message :

**Error response Error code 501. Message: Unsupported method ('GET').

Error code explanation: 501 = Server does not support this operation.**

For information i have another postgresql server (postgis) on my station using too the port by default 5432

Please find below openerp-server.conf :

[options] without_demo = False netport = 8070 server_actions_allow_code = False secure = False demo = {} syslog = False list_db = True cache_timeout = 100000 port = 8069 reportgz = False secure_pkey_file = server.pkey netinterface = log_level = info admin_passwd = admin smtp_port = 25 smtp_server = localhost db_user = openpg price_accuracy = 2 login_message = False import_partial = soap = False pidfile = False db_maxconn = 64 stop_after_init = True smtp_password = False xmlrpc = True db_port = 5432 debug_mode = False netrpc = True secure_cert_file = server.cert interface = logfile = C:\Program Files (x86)\OpenERP AllInOne\Server\openerp-server.log csv_internal_sep = , pg_path = C:\Program Files (x86)\OpenERP AllInOne\PostgreSQL\bin translate_modules = ['all'] smtp_ssl = False root_path = C:\Program Files (x86)\OpenERP AllInOne\Server smtp_user = False db_password = openpgpwd db_name = False db_host = 127.0.0.1 assert_exit_level = warn email_from = False addons_path = C:\Program Files (x86)\OpenERP AllInOne\Server\addons


Could you throw light for me?

Thanks.

Regards.

Hi , it seems to me that you have some modules not working but can you give us more informations ? such as is the postgres running ? or u can show us your log file at C:\Program Files (x86)\OpenERP AllInOne\Server\openerp-server.log

kalmenchia
on 5/14/13, 11:53 AM

Hello. Thank you for your reply. Yes i have checked services. I had to stop services for my postgres 9.1 postgis database. And services for OpenERPServer/OpenERPServer7.0/OpenERPweb/PostgresSQLforopenERP run. I send you screenshot of my Services setting. I noticed different setting regarding the column called "open a session as". The value is ".\postgres for OpenERP Server and .\openpgsvc for PostgresqlforOpenERP...

Latitude Geosystems SAS, Sales
on 5/14/13, 12:28 PM

Hello, sorry but i would like post my SS and the log file but i can't to do it. When i try to browse a file, i have a message error saying : "sorry, file uploading requires karma >30".

But i can send the usefull files on your mail if you want.

Thank you.

Latitude Geosystems SAS, Sales
on 5/14/13, 12:49 PM
0
Sales
On 5/14/13, 12:49 PM

Hello, sorry but i would like post my SS and the log file but i can't to do it. When i try to browse a file, i have a message error saying : "sorry, file uploading requires karma >30".

But i can send the usefull files on your mail if you want.

Thank you.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 5/14/13, 11:04 AM
Seen: 3299 times
Last updated: 3/16/15, 8:10 AM