Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


OpenERP7, new user with full rights unable to create new partners

on 2/8/13, 7:36 AM 6,868 views

With the admin user I can do everything, add, delete, modify, etc. As it should be.

Then using this user added a new one, with full access to sales and accounting options as some other ones needed for sales operations. Then tried to add a new supplier and it throws a warning:

Access Denied
The requested operation cannot be completed due to security restrictions. Please contact your system administrator.
(Document type: Pricelist, Operation: read)

Tested all the possible combinations on user rights and ended up giving full access to all options. Nevertheless I'm unable to create any new contact/customer/supplier/etc with this user. I'm running out of options, I don't know what else to test or where to look.


We have 3 companies, no hierarchical structure, all are on the "root" of the organization. None of them is on selected on the "Default Sales Pricelist". For now we have only one warehouse for the stock of one of the companies. And the two default locations for Stock and Output.


Just in case looking for the answer, it is on the comments of the selected answer. It is a reported bug. Go to multi company Access Denied Document type: Partner, Operation: read where the bug was reported and is followed up by other users.

On 2/8/13, 9:44 AM
  1. Try to uncheck access right Portal.

  2. This is a problem with purchase price list. If you dont use purchase price lists, then easiest way to solve the problem is make empty field Company in Purchases / Configuration / Pricelists for Default Purchase Pricelist with administrator privileges. If you cant see this option, then activate it Settings / Configuration / Purchases / check Manage pricelist per suplier -> Apply. After changes you can uncheck this box.

Uncheking access rights to Portal partially worked. The warning still appears but when I click OK, fill the supplier and save, the new supplier is added without errors. Any recommendation?

on 2/8/13, 10:03 AM

Sorry for not answering before, I don't have access to the server from home. Tested first hour today, the field you pointed out was already empty.

on 2/11/13, 4:12 AM

do you have some company in Default Sales Pricelist?

on 2/11/13, 4:23 AM

Question edited to add needed details.

on 2/11/13, 4:29 AM

Is the warning for all 3 companies or only for 2 or 1 company?

on 2/11/13, 5:07 AM

For all the 3 companies

on 2/11/13, 5:25 AM

Sorry, but i dont have any other idea how to help you (i cant to reproduce exactly your problem). Very similar problem is here https://bugs.launchpad.net/openobject-addons/+bug/1073087 only for Partner list. This could be a bug.

on 2/11/13, 7:54 AM

Correct, the link you pointed out seems to be exactly the error I'm experiencing with my enviroment configuration. Nevertheless should check more as on my local enviroment I don't have the error... really weird.

on 2/11/13, 9:26 AM
Abner Galeno Jr.
On 2/8/13, 10:36 AM

It could be with multi-company settings, which is still a fuzzy topic for me.

When I first worked with OpenERP7, I immediately enabled/checked the option Manage multiple companies under

Settings Module -> Configuration -> General Settings

then proceeded to work with multiple companies, setting up the parent, and the child companies.

That's where the ..security restriction... error messages showed up. I gave up testing the multi company module/setup, so I don't encounter those errors anymore.

I think it's because I have no idea what company my settings/changes are applied to. Maybe I should have made some users with access to only one company at each given time, and change the settings only when I'm logged as those users.

I have indeed the multi-company option selected, but this is a must for us as we have 4 companies. I have it also on my local development enviroment and I do not have these errors. I'm trying to find the error by comparing both enviroments, but no luck.

on 2/8/13, 10:49 AM
Tom Arnst
On 2/8/13, 11:03 AM

We have the same thing with no multi-company enabled.

Thanks. But remember that this should be a comment, not an answer. This was posted as an answer, but it does not attempt to answer the question. It should possibly be an edit, a comment, another question, or deleted altogether. Check SO faq's http://stackoverflow.com/questions/how-to-answer

on 2/8/13, 11:12 AM

Ok I see.. sorry for that.

Tom Arnst
on 2/8/13, 11:24 AM

No need to sorry, everyone of us someday was also new on these kind of sites and made same mistakes. That is way I pointed out to the StackOverflow faq and how to answer.

on 2/8/13, 11:26 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

6 follower(s)


Asked: 2/8/13, 7:36 AM
Seen: 6868 times
Last updated: 3/16/15, 8:10 AM