Help

6

openerp V8 wkhtmltopdf 0.12.0 error/bug ?

Hi, i've got wkhtmltopdf 0.12.0 version, I can't print invoices, quotation, rfq etc. I've got following error :

Report (PDF) wkhtmltopdf failed with error code = -11. Message: Loading pages (1/6) [> ] 0% [======> ] 10%

Any ideas ?

Thanks in advance .

Avatar
Discard
14 Answers
12
Avatar
swapnil wagh
Best Answer

Please follow below steps

 

1) Download wkhtmltopdf version from wkhtmltopdf.org depend on your system arch (32 or 64 bit)

   

    wget wget http://downloads.sourceforge.net/project/wkhtmltopdf/0.12.1/wkhtmltox-0.12.1_linux-trusty-amd64.deb

 

2) Install the package using commnad :

 

   sudo dpkg -i wkhtmltox-0.12.1_linux-trusty-amd64.deb 

 

3) Copy binary or wkhtmltopdf to /usr/bin location from ./usr/local/bin use command

     

    sudo cp /usr/local/bin/wkhtmltopdf /usr/bin/

 

4) Restart Odoo server and try once again.

2 Comments
Avatar
Discard
Avatar
Fadel Damen Schreiner
-

I need install modulo webkit before reinstall wkhtmltopdf

Avatar
Francesco Faleschini
-

Please notice files are now placed at http://download.gna.org/wkhtmltopdf/0.12/0.12.1/

1
Avatar
Lucas Huber
Best Answer

I did have the same problem on a site with a lot of consuming modules. The solution in my case was to increase the Multiprocessing options. Here is what I have now, but it is not optimized yet. Could easy be that not all of this is necessary.

##############################################
# Multiprocessing options
# Specify the number of workers, 0 disable prefork mode.
workers = 2
# Maximum allowed virtual memory per worker, when reached the worker be reset after the current request (default 671088640 aka 640MB)
limit_memory_soft = 888777666
# Maximum allowed virtual memory per worker, when reached, any memory allocation will fail (default 805306368 aka 768MB)
limit_memory_hard = 1999888777
# Maximum allowed CPU time per request (default 60)
limit_time_cpu = 80
# Maximum allowed Real time per request (default 120)
limit_time_real = 120
# Maximum number of request to be processed per worker (default 8192)
limit_request = 12000
# port for gevent processes has  worker (default 8072)
# reverse proxy 8072 port to the external 80, only for location /longpolling (in nginx this is done with a second location)
longpolling_port = 8083

 

Avatar
Discard
1
Avatar
Hugo Santos
Best Answer

I think this problem is related to the use of multicorn workers.
If I print any webkit report with 0.12.1 wkhtmltopdf and 0 workers works perfectly. If I use workers throws the mentioned error (The command 'wkhtmltopdf' failed with error code = -11. Message: No diagnosis message was provided).

Using wkhtmltopdf in version 0.11.0rc1 works with and without workers.

I've debugged the code of report_webkit module and that error is throwed in the call of wkhtmltopdf command, but showing the command that is going to be called and executing it in a terminal works perfect to.

Avatar
Discard
1
Avatar
Timo Goosen
Best Answer

Try this:

 

Solution: (Look in the comments)
http://www.theopensourcerer.com/2014/09/how-to-install-openerp-odoo-8-on-ubuntu-server-14-04-lts/comment-page-1/#comment-351536 Install Odoo8 on Ubuntu 14.04

Here is the solution from the comments:

#to solve wkhtmltopdf issue (report are empty or version error) use this :
$ sudo wget http://jaist.dl.sourceforge.net/project/wkhtmltopdf/0.12.1/wkhtmltox-0.12.1_linux-trusty-amd64.deb
$ sudo dpkg -i wkhtmltox-0.12.1_linux-trusty-amd64.deb
$ sudo cp /usr/local/bin/wkhtmltopdf /usr/bin
$ sudo cp /usr/local/bin/wkhtmltoimage /usr/bin
</pre>

You might still have the error popup after this, but the pdf's will print out correctly.

Avatar
Discard
0
Avatar
Jerome Sonnet
Best Answer

This problem has disappeared for me by increasing limit-memory-hard parameter in config file.

Avatar
Discard
0
Avatar
Rachid
Best Answer

Go to system parameters

then add a new key  :report.url

and the value :

http://localhost:8069/

Avatar
Discard
0
Best Answer

Did follow the steps and now it does not show error when I print PDF button from Odoo app but it generates the PDF file with Zero KB size. However running wkhtmltopdf http://www.odoo.com test.pdf from terminal it works fine.

Any idea?

Avatar
Discard
0
Best Answer

On ubuntu, install wkhtltopdf thru apt then, download the latest version from the wkhtml website extract the file and overwrite the wkhtmltopdf file in /usr/bin/ with the one extracted ! 

Avatar
Discard
0
Avatar
Romain Deheele
Best Answer

It could possibly be a memory allocation problem.

This problem has disappeared for me by increasing limit-memory-hard parameter in config file.

 

 

Avatar
Discard
0
Avatar
SonnyV
Best Answer

Many good answers here about manually installing the latest version from wkhtmltopdf. The only thing I'd recommend is using 'ln -s /usr/local/bin/wkhtmltopdf /usr/bin/wkhtmltopdf' after installing the deb. Instead of copying the files it makes a symbolic link. So if you remove wkhtml or upgrade it, the symbolic link will change accordingly.

Regards

 

Avatar
Discard
0
Avatar
Rui Andrada
Best Answer

I think the best way to get wkhtmltopdf working on Ubuntu 14.04(or other version) is get the lastest version from website project from http://wkhtmltopdf.org/downloads.html

Get the right version for your system Like Ubuntu 64 bits or 32 bits, or your for system you didn't mentioned.
use "sudo dpkg" to install the package 

sudo dpkg -i wkhtmltox-0.12.1_linux-trusty-amd64.deb # if you downloaded for 64 bits

maybe you got errors because of libc6, if happens try to fix it with:

sudo apt-get -f install

After that, you have the updated version of wkhtmltopdf from package wkhtmltox which  removes wkhtmltopdf package if installed.

You can check if wkhtmltopdf is working with:

wkhtmltopdf http://www.odoo.com test-odoo.pdf

Check out pdf file is odoo website.

After that, restart Odoo server and try again.

Avatar
Discard
-1
Avatar
klacus
Best Answer

Please post this result.

cat /var/log/syslog | grep wkhtmltopdf

After we can see what is the root cause..

you can check by root mode with the follwoing command

sudo  /usr/local/bin/wkhtmltopdf google.com /tmp/teszt.pdf

if will run, without problem in terminal you have some permission problem...

 

 

Avatar
Discard
-1
Avatar
Yves Goldberg
Best Answer

thank you Christian. It did for me but how do you get rid of the error message that "you should upgrade to....." that pops up each time you print a report?

cheers.

1 Comment
Avatar
Discard
Avatar
Yves Goldberg
-

Yes, I did the same and I am not having problem in Ubuntu 14.04.

-1
Best Answer

Which protocol that you guys are using?

Normally it works well in http but getting errors with https.

Avatar
Discard