Odoo Help

0

openerp.service: Failed to load server-wide module `web`

By
Vale Trood
on 8/11/15, 5:44 AM 5,124 views

Hi Friends!!!

Please, i want to return working with OpenERP7.

The problem is that when i run it on my machine i got this error:


2015-08-11 09:41:44,511 4528 INFO ? openerp: addons paths: /opt/openerp/v7/server/openerp/addons

2015-08-11 09:41:44,512 4528 INFO ? openerp: database hostname: localhost

2015-08-11 09:41:44,512 4528 INFO ? openerp: database port: 5432

2015-08-11 09:41:44,512 4528 INFO ? openerp: database user: rihene

2015-08-11 09:41:44,512 4528 WARNING ? openerp.modules.module: module web: module not found

2015-08-11 09:41:44,513 4528 CRITICAL ? openerp.modules.module: Couldn't load module web

2015-08-11 09:41:44,513 4528 CRITICAL ? openerp.modules.module: No module named web

2015-08-11 09:41:44,513 4528 ERROR ? openerp.service: Failed to load server-wide module `web`.

The `web` module is provided by the addons found in the `openerp-web` project.

Maybe you forgot to add those addons in your addons_path configuration.

Traceback (most recent call last):

File "/opt/openerp/v7/server/openerp/service/__init__.py", line 60, in load_server_wide_modules

openerp.modules.module.load_openerp_module(m)

File "/opt/openerp/v7/server/openerp/modules/module.py", line 405, in load_openerp_module

__import__('openerp.addons.' + module_name)

File "/opt/openerp/v7/server/openerp/modules/module.py", line 132, in load_module

f, path, descr = imp.find_module(module_part, ad_paths)

ImportError: No module named web

2015-08-11 09:41:44,513 4528 WARNING ? openerp.modules.module: module web_kanban: module not found

2015-08-11 09:41:44,513 4528 CRITICAL ? openerp.modules.module: Couldn't load module web_kanban

2015-08-11 09:41:44,513 4528 CRITICAL ? openerp.modules.module: No module named web_kanban

2015-08-11 09:41:44,513 4528 ERROR ? openerp.service: Failed to load server-wide module `web_kanban`.

Traceback (most recent call last):

File "/opt/openerp/v7/server/openerp/service/__init__.py", line 60, in load_server_wide_modules

openerp.modules.module.load_openerp_module(m)

File "/opt/openerp/v7/server/openerp/modules/module.py", line 405, in load_openerp_module

__import__('openerp.addons.' + module_name)

File "/opt/openerp/v7/server/openerp/modules/module.py", line 132, in load_module

f, path, descr = imp.find_module(module_part, ad_paths)

ImportError: No module named web_kanban

2015-08-11 09:41:44,518 4528 INFO ? openerp.service.wsgi_server: HTTP service (werkzeug) running on 0.0.0.0:8069

2015-08-11 09:41:44,518 4528 INFO ? openerp: OpenERP server is running, waiting for connections...

2015-08-11 09:41:50,295 4528 INFO ? werkzeug: 127.0.0.1 - - [11/Aug/2015 09:41:50] "GET / HTTP/1.1" 404 -

Here is my openerp-server.conf file:


[options]

; This is the password that allows database operations:

; admin_passwd = admin

db_host = False

db_port = False

db_user = ubuntu

db_password = False

addons_path = /opt/openerp/v7/addons,/opt/openerp/v7/web/addons, /opt/openerp/v7/web/addons/web_kanban

Please, who can help me.

Regards.

0

Vale Trood

--Vale Trood--

1165
| 5 2 7
Tunis, France
--Vale Trood--


Vale Trood
On 8/11/15, 9:38 AM

I found the solution Guys!!

Now everything work fine:

So i have deleted the addons and redownload them from https://www.odoo.com/fr_FR/page/download.

And my openerp_server.conf file is:

[options]

; This is the password that allows database operations:

; admin_passwd = admin

db_host = localhost

db_port = 5432

db_user = odoo

db_password = odoo

addons_path = /opt/openerp/v7/addons

Regards.

0

Serpent Consulting Services Pvt. Ltd.

--Serpent Consulting Services Pvt. Ltd.--
Serpent Consulting Services Pvt. Ltd.
http://www.serpentcs.com
4693
| 6 6 8
Gandhinagar, India
--Serpent Consulting Services Pvt. Ltd.--

Serpent Consulting Services Pvt. Ltd. Your Odoo/OpenERP Solution, just an email away!

Serpent Consulting Services Pvt. Ltd.
On 8/11/15, 5:50 AM

Hello,

/opt/openerp/v7/addons,/opt/openerp/v7/web/addons  should be right. Make sure you have the modules under these path and the files have enough access.

Thanks.

I have made sure that i have the modules under these path but it still NOT WORKING :/

Vale Trood
on 8/11/15, 5:54 AM

Your config file is not being considered. See the first line:2015-08-11 09:41:44,511 4528 INFO ? openerp: addons paths: /opt/openerp/v7/server/openerp/addons ...Says your config file is not being taken into consideration. Make sure you pass the right config file while starting the server.

Serpent Consulting Services Pvt. Ltd., Serpent Consulting Services Pvt. Ltd.
on 8/11/15, 6:29 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 8/11/15, 5:44 AM
Seen: 5124 times
Last updated: 8/11/15, 9:38 AM