Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

openERP Server Access Denied when try create database ?

By
mcindietech
on 4/8/13, 12:17 PM 28,183 views

Hi, I have just installed OpenERP v7.0 on a Centos 6.3 server (minimal x64) with PostgreSQL 9.2 and now when I try create db from db manager in OpenERP Web Interface, the application show me this error:

OpenERP Server Error (code) Server Access denied.

I have used a script to install openERP, and works fine...but when I try create db from web interface, doesn't work. During script execution doesn't tell me nothing about master password of postgres or similar.

Thanks!

createdb -O bn_openerp testdb

Maxime Chambreuil
on 4/8/13, 11:32 PM
3
Maxime Chambreuil
On 4/8/13, 11:43 PM

You can give bn_openerp user the right to create database (superuser), so you won't need to go through the cli to manage DB.

http://doc.openerp.com/v7.0/install/linux/postgres/index.html#first-method

Thanks! solved.

mcindietech
on 4/12/13, 8:41 AM

Click on the check mark on the left then ;)

Maxime Chambreuil
on 4/17/13, 10:10 PM
0
vk
On 6/3/14, 5:21 AM

Solved. The problem is that script doesn't create any database for openerp. Solution: postgres=# create database testdb; postgres=# alter database testdb owner to bn_openerp;

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 4/8/13, 12:17 PM
Seen: 28183 times
Last updated: 5/24/15, 1:37 AM