Odoo Help


openerp 7 performance

on 3/11/13, 9:26 AM 2,366 views

Manufacturing order of a product(BOM with 200 parts) is taking more than 5 min...what is wrong ??

On 4/3/14, 1:55 PM

All the MRP work with browse object ... that SO SO SLOW, read all field in a record and use only a few, MRP module need to be re-write to avoid use of browse. My Little Opinion

On 3/11/13, 3:40 PM

There might be many answers to your questions. Looks like a database tuning problem, or a resource problem in your server. Have you checked your CPU usage in your server? Are other users able to work with OpenERP?

On 9/19/14, 7:13 AM


Please chage your server configuration file with following.

# Specify the number of workers, 0 disable prefork mode.
workers = 0

# Maximum allowed virtual memory per worker, when reached the worker be reset after the current request (default 671088640 aka 640MB)
limit_memory_soft = 671088640

# Maximum allowed virtual memory per worker, when reached, any memory allocation will fail (default 805306368 aka 768MB)
limit_memory_hard = 805306368

# Maximum allowed CPU time per request (default 60)
limit_time_cpu = 60

# Maximum allowed Real time per request (default 120)
limit_time_real = 120

# Maximum number of request to be processed per worker (default 8192)
limit_request = 8192

Check Link for more.





About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

0 follower(s)


Asked: 3/11/13, 9:26 AM
Seen: 2366 times
Last updated: 3/16/15, 8:10 AM