Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

OpenERP 7 error after upgrading EDI module

By
Steve McGough
on 5/30/13, 9:16 AM 1,675 views

Hello, Any insights on this would be greatly appreciated.

I have been evaluating openerp 7.0 on an Ubuntu server. After installing the EDI module, I clicked "upgrade". This caused an error that now won't allow me to log into the system. I got the same error message (I think) clicking on each link. Then after logging out, when I tried to log in I got the same message again. I'm new to python & anyone's insights would be greatly appreciated. Below is the error message I get when trying to login (hopefully it is formatted in a way that is easy to read):

OpenERP Server Error

Client Traceback (most recent call last): File "/usr/lib/pymodules/python2.7/openerp/addons/web/http.py", line 204, in dispatch response["result"] = method(self, **self.params)

File "/usr/lib/pymodules/python2.7/openerp/addons/web/controllers/main.py", line 860, in authenticate req.session.authenticate(db, login, password, env)

File "/usr/lib/pymodules/python2.7/openerp/addons/web/session.py", line 115, in authenticate uid = self.proxy('common').authenticate(db, login, password, env)

File "/usr/lib/pymodules/python2.7/openerp/addons/web/session.py", line 30, in proxy_method result = self.session.send(self.service_name, method, *args)

File "/usr/lib/pymodules/python2.7/openerp/addons/web/session.py", line 103, in send raise xmlrpclib.Fault(openerp.tools.ustr(e), formatted_info)

Server Traceback (most recent call last):

File "/usr/lib/pymodules/python2.7/openerp/addons/web/session.py", line 89, in send return openerp.netsvc.dispatch_rpc(service_name, method, args)

File "/usr/lib/pymodules/python2.7/openerp/netsvc.py", line 292, in dispatch_rpc result = ExportService.getService(service_name).dispatch(method, params)

File "/usr/lib/pymodules/python2.7/openerp/service/web_services.py", line 433, in dispatch return fn(*params)

File "/usr/lib/pymodules/python2.7/openerp/service/web_services.py", line 444, in exp_authenticate res_users = pooler.get_pool(db).get('res.users')

File "/usr/lib/pymodules/python2.7/openerp/pooler.py", line 49, in get_pool return get_db_and_pool(db_name, force_demo, status, update_module)[1]

File "/usr/lib/pymodules/python2.7/openerp/pooler.py", line 33, in get_db_and_pool registry = RegistryManager.get(db_name, force_demo, status, update_module)

File "/usr/lib/pymodules/python2.7/openerp/modules/registry.py", line 192, in get update_module)

File "/usr/lib/pymodules/python2.7/openerp/modules/registry.py", line 218, in new openerp.modules.load_modules(registry.db, force_demo, status, update_module)

File "/usr/lib/pymodules/python2.7/openerp/modules/loading.py", line 341, in load_modules processed = load_marked_modules(cr, graph, states_to_load, force, status, report, loaded_modules, update_module)

File "/usr/lib/pymodules/python2.7/openerp/modules/loading.py", line 256, in load_marked_modules loaded, processed = load_module_graph(cr, graph, progressdict, report=report, skip_modules=loaded_modules, perform_checks=perform_checks)

File "/usr/lib/pymodules/python2.7/openerp/modules/loading.py", line 192, in load_module_graph load_demo(module_name, idref, mode)

File "/usr/lib/pymodules/python2.7/openerp/modules/loading.py", line 77, in <lambda> load_demo = lambda *args: _load_data(cr, *args, kind='demo')

File "/usr/lib/pymodules/python2.7/openerp/modules/loading.py", line 124, in _load_data tools.convert_xml_import(cr, module_name, fp, idref, mode, noupdate, report)

File "/usr/lib/pymodules/python2.7/openerp/tools/convert.py", line 954, in convert_xml_import obj.parse(doc.getroot())

File "/usr/lib/pymodules/python2.7/openerp/tools/convert.py", line 847, in parse self._tagsrec.tag

File "/usr/lib/pymodules/python2.7/openerp/tools/convert.py", line 814, in _tag_record id = self.pool.get('ir.model.data')._update(cr, self.uid, rec_model, self.module, res, rec_id or False, not self.isnoupdate(data_node), noupdate=self.isnoupdate(data_node), mode=self.mode, context=rec_context )

File "/usr/lib/pymodules/python2.7/openerp/addons/base/ir/ir_model.py", line 963, in _update res_id = model_obj.create(cr, uid, values, context=context)

File "/usr/lib/pymodules/python2.7/openerp/addons/base/res/res_partner.py", line 498, in create new_id = super(res_partner, self).create(cr, uid, vals, context=context) File "/usr/lib/pymodules/python2.7/openerp/addons/mail/mail_thread.py", line 242, in create thread_id = super(mail_thread, self).create(cr, uid, values, context=context)

File "/usr/lib/pymodules/python2.7/openerp/osv/orm.py", line 4434, in create cr.execute('insert into "'+self._table+'" (id'+upd0+") values ("+str(id_new)+upd1+')', tuple(upd2))

File "/usr/lib/pymodules/python2.7/openerp/sql_db.py", line 161, in wrapper return f(self, args, *kwargs)

File "/usr/lib/pymodules/python2.7/openerp/sql_db.py", line 226, in execute res = self._obj.execute(query, params)

IntegrityError: null value in column "name" violates not-null constraint

0
Mark Propp
On 10/29/13, 1:11 AM

Your question has gone unanswered for 5 months, so it is probably moot by now. But perhaps this will help others.

I have also experienced this problem when installing or upgrading modules. The answer I have found elsewhere is to use the GUI, go to Installed Modules, and cancel the install / upgrade.

But in a recent case, I tried to upgrade the Base module, and it left things in such a bad state I could not login to the GUI. Every time I would receive the same error you posted.

The solution was to edit the DB directly (e.g. with pgadmin or psql).

There is a table that stores the state of the modules ('installed', 'to install", 'to upgrade'. You can change the 'to install' or 'to upgrade' state thusly:

update ir_module_module set state='installed' where state='to upgrade'

Then I could login to the system, back to previous state.

Now I need to research how to upgrade and install modules without causing this problem. Some forum searches indicate that the source must be upgraded first, and that there is an issue with having started with "demo data".

Wish you good luck!

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 5/30/13, 9:16 AM
Seen: 1675 times
Last updated: 3/16/15, 8:10 AM