Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

[Odoo v8] Can't get default database with website in Odoo

By
Anas ea
on 8/21/14, 6:16 AM 924 views

Hello,

I have Odoo instalation with 3 databases, one of them I defined in the config file to be default (db_name=...),
However whenever I go to the main address of odoo instalation I get to the login/selectdb screen and Not the website I have in that database!

I've tried launching openerp-server with -d  and also the db_filter in odoo config file none of them worked.

Thanks you!

0
Julien Laloux
On 8/21/14, 11:22 AM

Did you try launching Odoo with the argument "--db_filter"?

Yes i did try it with no luck!

Anas ea
on 8/22/14, 4:45 AM
0
Peter Gandert
On 8/26/14, 7:08 PM

Hello,

I had the same problem. The only way to solve it is to call odoo with the parameter db in the URL. For example: mysite.com/db=mydatabase2. Then the website from database2 will be displayed.

I think the reason is that odoo must know the database for displaying the desired website. If you start odoo without the db parameter then the standard login screen will be displayed.

 

 

Thank you for your reply, adding ?db=DesiredDB would go to the login screen of that db but not directly to the website thanks

Anas ea
on 9/29/14, 7:06 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 8/21/14, 6:16 AM
Seen: 924 times
Last updated: 3/16/15, 8:10 AM