Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo loading forever after installing module account.

on 12/5/14, 6:07 AM 2,515 views

Hi ! 

I'm just trying to use odoo now (v8).

I've just installed one module, the module account_voucher.

But, the thing is, after it has been installed, I can no longer acess to the Local Modules section. The page just load forever, whith a classic xmlhttprequest error after a while. In the log, nothing to note, just POST requests...

I've tried it on another database, and still the same issue.

Any idea on what's causing this behavior ?

Thanks !


Uninstalling this account_voucher module does not fix the issue.

After the error message, you can click on the config menu again and it loads this time.

I just did a git pull to update odoo, still the same issue.

Upgrading postgresql from 9.1 to 9.3 did not solve the issue.

Deleted the odoo server, all the databases, got odoo again from source, re-installing, etc didn't solve it...

No one can answer this ? I checked the permissions on the server side, with no luck. It is the server that causes that issue, because I don't have this problem on my laptop or in my vm I built for tests. Please some help, ideas, clues....

Check the request from your browser to see what request still waiting the response. This can give you some clues where to start debugging.

Ben Bernard
on 12/18/14, 4:41 AM

I did that, but we just did some serious tests, and I know now what was causing this issue.

on 12/18/14, 4:48 AM
On 12/18/14, 4:49 AM

In fact, that was an issue with our internet connection... Sorry for the troubles.

lol. This is usually the reason why I need a partner :D

Ben Bernard
on 12/18/14, 5:07 AM


| 5 4 6
Zagreb | Karlovac, Croatia

there is only 10 kind of people the ones that understand binary ... and others

On 12/5/14, 6:29 AM

IN v8 realy takes a long time to load chart of account template... 
it is not related to specific revision, i have experienced such behaivour a lot of times, and can't realy say why.. 
but i'll give you a clue.. my chart of accounts has some 2800 lines ( accoutns) .. and it took almost 45 inutes to looad as template,
and almost an hour to  apply that template to company.. 

so .. in total, a bit less then 2 hours was average time to install module account (sale also, because it is dependent  on account module) 

the weirderst thing is, it does not happen on all environments... 
And as i said.. i can't pin-point on the problem... 

I agree with that. On my local computer, I've not these problems that I described, so it seems indeed that it's environment dependent. I also noticed that installing a module can take a longer time than in the 7 version. Still diging...

on 12/8/14, 3:07 AM
Joshua Smith
On 11/6/15, 8:27 PM

We are having the same problem. Running v9 on a Windows 10 64bit for testing. We have a 50 Mbps internet connection, with wired network and all modern network gear. The server running the software has 4gb, a SSD and i5 processor and shows almost no load. But Odoo runs dog slow. Also it hangs up installing just about any module.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)


Asked: 12/5/14, 6:07 AM
Seen: 2515 times
Last updated: 11/6/15, 8:27 PM