Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Odoo connection trouble with Postgre

By
Odoo Mint
on 8/10/14, 7:08 AM 4,112 views

Hi all,

I just installed Odoo in Linux Mint. The installation process was correct. I  have lost the database data when I installed Postgre and when I start openerp-server and load localhost:8069, the webpage displays:
"The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application."

And in Odoo log the error is:
2014-08-10 11:02:55,941 4924 ERROR ? openerp.addons.bus.bus: Bus.loop error, sleep and retry
Traceback (most recent call last):
  File "/home/xxxx/odoo/openerp/addons/bus/bus.py", line 136, in run
    self.loop()
  File "/home/xxxx/odoo/openerp/addons/bus/bus.py", line 114, in loop
    with openerp.sql_db.db_connect('postgres').cursor() as cr:
  File "/home/xxxx/odoo/openerp/sql_db.py", line 565, in cursor
    return Cursor(self.__pool, self.dbname, serialized=serialized)
  File "/home/xxxx/odoo/openerp/sql_db.py", line 176, in __init__
    self._cnx = pool.borrow(dsn(dbname))
  File "/home/xxxx/odoo/openerp/sql_db.py", line 458, in _locked
    return fun(self, *args, **kwargs)
  File "/home/xxxx/odoo/openerp/sql_db.py", line 521, in borrow
    result = psycopg2.connect(dsn=dsn, connection_factory=PsycoConnection)
  File "/usr/local/lib/python2.7/dist-packages/psycopg2-2.5.3-py2.7-linux-i686.egg/psycopg2/__init__.py", line 164, in connect
    conn = _connect(dsn, connection_factory=connection_factory, async=async)
OperationalError: fe_sendauth: no password supplied


how can I correct it and configure correctly the data connection between Odoo and Postgre?
I'm new with these programs and thank a detailed step by step help to solve :)

Thanks in advance!

0
S. Edelman
On 9/13/16, 4:11 PM

I also got this (in Odoo 9.0c), looking logs it seems this morning came the first 
"openerp.addons.bus.models.bus: Bus.loop error, sleep and retry - - " etc. 

and after that I couldn't get the website, frontend of backend loading. The system has been running since July, so it is mysterious why an earth is not suddenly running anymore. It has initiated the shutdown (openerp.service.server: Initiating shutdown) 1 minute before this bus.loop error. Nothing strange in the logs happening before that.

Could it be some Linux update (ubuntu 16.04) that would have got into effect only after the server shutdown and caused the issue? Nobody used the system during weekend and before this morning when it was already down.

I have tried to look all logs but do not know any other way I could debug this since I can't see the system!

0

Ben Bernard

--Ben Bernard--
1083
| 4 3 6
Jakarta, Indonesia
--Ben Bernard--
Ben Bernard
On 8/10/14, 10:00 AM

It looks like a postgresql config issue. You can

1. Allow connection with no password to postgresql. To do this edit your pg_hba.conf and add/edit line with something like this

local    all    all    trust

2. You already have role in postgresql and know the user/password combination. In this case set the password in db_password option in openerp-server.conf

0
Mariusz Mizgier
On 8/10/14, 9:12 AM

You are trying to connect to openerp database without providing a password in config file - seems like user you've created has got a password and your db_password is not set in openerp-server.conf.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 8/10/14, 7:08 AM
Seen: 4112 times
Last updated: 9/14/16, 3:51 AM