Odoo Help

0

Odoo 9 attachment module 500 error, bug?

By
Mark Leemans
on 9/29/15, 8:38 AM 1,732 views

I'm testing Odoo9 and i've installed the Attachment module. Uploading a attachment works fine, but when I try to download an attachment a internal server error (500) occurs. For example:

https://odoo.internal/web/content/609?download=true&t=1443530036375


In the errorlog I get this error:

TypeError: content_common() got an unexpected keyword argument 't'


And when I remove the t argument from the URL I can download the file perfectly fine:

https://odoo.internal/web/content/609?download=true


I've tried to simulate your problem on the latest runbot and it doesn't seem to be there anymore. Please update your Odoo V9 to the latest version and see if you still have that issue? :)

Yenthe
on 9/29/15, 8:59 AM

Hi Yenthe, strange. Because the runbot version doesn't append the t argument. Gonna try the latest update.

Mark Leemans
on 9/29/15, 9:03 AM
0
Mark Leemans
On 9/30/15, 5:18 AM

Still not fixed in the latest nightly build..

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 9/29/15, 8:38 AM
Seen: 1732 times
Last updated: 9/30/15, 5:18 AM