Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo 8 hanging in settings & apps too often and too long

Kirthi S
on 4/28/15, 10:55 PM 441 views

Anyone else facing this issue - Too often, the application get stuck with the 'Loading...' prompt, and never comes back. The only option is to close the browser and login to the application all over again. This happens mostly in settings page.

I'm running Odoo server 8.0 in a Ubuntu box. Any suggestions on how this can be prevented? This is error is so often that it's frustrating to use the application.

Are you working locally on the server or over the network. If so, are you on a gigabit network or something slower, like over the wan? What kind of resources does your server have: ram/cpu?

Michael Thomas
on 4/29/15, 12:19 AM

It's over the network - not on gigabit, slower connection. Server is hosted as 512MB RAM, 20 GB SSD droplet in digitalocean. All installed modules do not buffer, but the settings page is the one that buffers a lot endlessly. I always have to resort to cloging the browser aftre waiting for 10 minor so.

Kirthi S
on 4/29/15, 1:22 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 4/28/15, 10:55 PM
Seen: 441 times
Last updated: 4/29/15, 1:22 AM