Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Invoice Number Sequence skip a number after invoice cancel, reset to draft and validate

By
Cidex
on 4/6/16, 12:18 PM 501 views

hi guys,

I'm testing Odoo Version 8. When I cancel an invoice, rest it to draft and validate it again the Invoice number skip the  Sequence and loose one number. 

For Example If I cancel invoice n. SAJ/2016/0008, than reset invoice to Draft state and validate it again I get Invoice n. SAJ/2016/0009. On number is lost. I do not think this is the correct behavior.

Even if I force the correct number using force invoice number, the following invoice number proposed by the system always skip one number.

I have to go to Setting / Sequences / Sequences / Sales Journal to recover the number.

Thank you for your help.

Thanks

MAX

0
Cidex
On 4/6/16, 4:22 PM

Hello Edser,

thank you for your reply. I tried to set it both way Implementation: Standard and no gap. The problem is not solved. I have account cancel installed to cancel the invoice.

Thanks

MAX

0
Edser Solis
On 4/6/16, 3:47 PM

Hello Max,

Try changing the sequence implementation to No Gap. It's weird how it's behaving because even on Standard I don't have that issue and as you're only testing Odoo I guess there's no one else but you giving input to the system but give it a try.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 4/6/16, 12:18 PM
Seen: 501 times
Last updated: 4/6/16, 4:22 PM