Odoo Help

0

Invisible field on create

By
George Tsagkogeorgas
on 11/6/13, 5:30 AM 1,121 views

When I want to create a new customer, customer boolean field is true by default.

In my inherited view I have the field cust_type:

<field name="cust_type" attrs="{'invisible':[('customer','!=',True)],'required':[('customer','=',True)]}"/>

Although, the customer field is True the cust_type field is invisible. When I unckeck and check again the customer field the cust _type becomes visible.

What can I do to have cust_type visible from the beginning?

I found the problem. When I try to create a new customer the boolean field customer by default is 1 and when check it and uncheck the customer field is true.

George Tsagkogeorgas
on 11/6/13, 6:34 AM
0
Abhishek H Menon
On 11/6/13, 6:30 AM

Set your field value cust_type as true in default for a customer

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

0 follower(s)

Stats

Asked: 11/6/13, 5:30 AM
Seen: 1121 times
Last updated: 3/16/15, 8:10 AM