Odoo Help

0

'Internal Server Error' after All in one install on Windows

By
BR
on 5/26/16, 3:43 PM 10,097 views

I get the following error in the after installing 9.0 Community on Windows Server 2003

Internal Server Error

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.

This is after the installation attempted to automatically launch Odoo by getting http://localhost:8069/

Any idea what might be going on here?


BR
Try to check logs, there you can find the exact issue,,, its basically because of coding issue only...

Pawan
on 5/27/16, 1:35 AM

Sorry for the long comment, but I'm apparently not authorized to update the question with additional information. After looking in the log, I'm wondering if this could this be related to an invalid PostgreSQL installation? I have no experience with PostgreSQL. Here is what I found in the openerp-server.log: 2016-05-26 20:05:57,515 4060 INFO ? openerp.addons.bus.models.bus: Bus.loop listen imbus on db postgres 2016-05-26 20:05:58,608 4060 INFO ? openerp.sql_db: Connection to the database failed 2016-05-26 20:05:58,608 4060 ERROR ? openerp.addons.bus.models.bus: Bus.loop error, sleep and retry Traceback (most recent call last): File "C:\Odoo 9.0-20160523\server\openerp\addons\bus\models\bus.py", line 168, in run File "C:\Odoo 9.0-20160523\server\openerp\addons\bus\models\bus.py", line 146, in loop File "C:\Odoo 9.0-20160523\server\.\openerp\sql_db.py", line 630, in cursor File "C:\Odoo 9.0-20160523\server\.\openerp\sql_db.py", line 164, in __init__ File "C:\Odoo 9.0-20160523\server\.\openerp\sql_db.py", line 513, in _locked File "C:\Odoo 9.0-20160523\server\.\openerp\sql_db.py", line 581, in borrow File "psycopg2\__init__.pyc", line 164, in connect OperationalError: could not connect to server: Connection refused (0x0000274D/10061) Is the server running on host "localhost" (127.0.0.1) and accepting TCP/IP connections on port 5432? I also found this in the openerp-server.conf: db_host = localhost db_maxconn = 64 db_name = False db_password = openpgpwd db_port = 5432 db_template = template1 db_user = openpg Does that look correct? Should db_name be false?

BR
on 5/27/16, 10:00 AM
1
Chandni
On 11/4/16, 6:14 AM

Hi,

Most likely there _is_ a firewall involved, maybe just not one you're aware of. Check the settings in the standard Windows Firewall.

For more troubleshooting: Check netstat to see if PostgreSQL is actually listening on the port you've configured. Use Wireshark to capture incoming tcp/ip traffic and see if (a) SYN packets to open the connection actually reach the server, and (b) whether the server actually replies with an RST to reject the connection or if something else happens.


If u have installed ODOO with port 5432 and postgreSQL is not supported, U have to change port to 5433. Try this it will definitely work.


Update here if more issues for the same.

2
Paul LeRoy
On 7/20/16, 12:16 AM

I'm also getting this error on starting Odoo installed locally on a windows machine.  After entering http://localhost:8069 I get the error:  Internal Server Error - 

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.

Anyone have an idea as to how to correct this?


 

0
Nugroho
On 5/8/18, 1:17 AM

I find the same problem after all in one installer on Windows 7, and I found:

1.  Postgresql is not installed at all. I cannot find it in Program Files and I check it using PgAdmin, not installed.   So I download and install Postgresql,  

2.  I search services on Windows. Odoo 10.0 service is also Disabled. So I set it automatic and start it.

So I must use PgAdmin to set the user for the postgresql manually. 

There is something wrong with odoo installer all in one for windows 7. 

 



0
Ejiogu Princewill
On 3/16/18, 12:25 AM

i have just installed odoo 10 and all the dependencies on ubuntu 16.04 LTS and my server is running fine but when i open localhost:8069 on firefox i get ERROR 500 internal server error see below my logs 

rexdomine@ubuntu:/opt/odoo/odoo-10.0$ ./odoo-bin 2018-03-16 04:14:08,796 8926 INFO ? odoo: Odoo version 10.0 2018-03-16 04:14:08,797 8926 INFO ? odoo: addons paths: ['/home/rexdomine/.local/share/Odoo/addons/10.0', u'/opt/odoo/odoo-10.0/odoo/addons', u'/opt/odoo/odoo-10.0/addons'] 2018-03-16 04:14:08,798 8926 INFO ? odoo: database: default@default:default 2018-03-16 04:14:08,920 8926 INFO ? odoo.service.server: HTTP service (werkzeug) running on 0.0.0.0:8069 Exception in thread odoo.service.httpd: Traceback (most recent call last): File "/usr/lib/python2.7/threading.py", line 801, in __bootstrap_inner self.run() File "/usr/lib/python2.7/threading.py", line 754, in run self.__target(*self.__args, **self.__kwargs) File "/opt/odoo/odoo-10.0/odoo/service/server.py", line 247, in http_thread self.httpd = ThreadedWSGIServerReloadable(self.interface, self.port, app) File "/opt/odoo/odoo-10.0/odoo/service/server.py", line 105, in __init__ handler=RequestHandler) File "/usr/lib/python2.7/dist-packages/werkzeug/serving.py", line 440, in __init__ HTTPServer.__init__(self, (host, int(port)), handler) File "/usr/lib/python2.7/SocketServer.py", line 417, in __init__ self.server_bind() File "/opt/odoo/odoo-10.0/odoo/service/server.py", line 115, in server_bind super(ThreadedWSGIServerReloadable, self).server_bind() File "/usr/lib/python2.7/BaseHTTPServer.py", line 108, in server_bind SocketServer.TCPServer.server_bind(self) File "/usr/lib/python2.7/SocketServer.py", line 431, in server_bind self.socket.bind(self.server_address) File "/usr/lib/python2.7/socket.py", line 228, in meth return getattr(self._sock,name)(*args) error: [Errno 98] Address already in use 

0
john doe
On 12/12/17, 3:33 PM

UPDATE: Installed it on C:\  - solved problems.

--- orig --

Is there an all in one installer version of odoo that will install and work on Windows 7?  I just want to install (any version at this point) on a Windows 7 machine.

I am getting the 500 Internal Server Error.  I suspect it's a configuration problem - accounts/passwords... something.  The installer finishes and I've turned off the firewall, but cannot connect on localhost:8069  5432 doesn't respond either.

 

Can anyone tell me if the Ubuntu installer works? 
0
Lilian
On 6/17/16, 4:08 AM

I am also experiencing the same problem. Does anyone have ideas how to deal with it?

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

2 follower(s)

Stats

Asked: 5/26/16, 3:43 PM
Seen: 10097 times
Last updated: 5/8/18, 1:17 AM