Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Internal Server Error after 2 days of work - OpenERP 7.0 (Win7 x64)

By
fabio
on 2/18/14, 12:49 PM 2,279 views

Hello everybody, I am new at OpenERP after 2 days of work it gave me this error message: Internal Server Error

{"message": "OpenERP Server Error", "code": 200, "data": {"debug": "Server Traceback (most recent call last):\n File \"C:\Program Files (x86)\OpenERP 7.0-20140217-002618\Server\server\openerp\addons\web\session.py\", line 89, in send\n File \"C:\Program Files (x86)\OpenERP 7.0-20140217-002618\Server\server\.\openerp\netsvc.py\", line 292, in dispatch_rpc\n File \"C:\Program Files (x86)\OpenERP 7.0-20140217-002618\Server\server\.\openerp\service\web_services.py\", line 122, in dispatch\n File \"C:\Program Files (x86)\OpenERP 7.0-20140217-002618\Server\server\.\openerp\service\web_services.py\", line 359, in exp_list\n File \"C:\Program Files (x86)\OpenERP 7.0-20140217-002618\Server\server\.\openerp\sql_db.py\", line 484, in cursor\n File \"C:\Program Files (x86)\OpenERP 7.0-20140217-002618\Server\server\.\openerp\sql_db.py\", line 182, in __init__\n File \"C:\Program Files (x86)\OpenERP 7.0-20140217-002618\Server\server\.\openerp\sql_db.py\", line 377, in _locked\n File \"C:\Program Files (x86)\OpenERP 7.0-20140217-002618\Server\server\.\openerp\sql_db.py\", line 440, in borrow\n File \"psycopg2\__init__.pyc\", line 178, in connect\nOperationalError: could not connect to server: Connection refused (0x0000274D/10061)\n\tIs the server running on host \"localhost\" (::1) and accepting\n\tTCP/IP connections on port 5432?\ncould not connect to server: Connection refused (0x0000274D/10061)\n\tIs the server running on host \"localhost\" (127.0.0.1) and accepting\n\tTCP/IP connections on port 5432?\n\n\nClient Traceback (most recent call last):\n File \"C:\Program Files (x86)\OpenERP 7.0-20140217-002618\Server\server\openerp\addons\web\http.py\", line 285, in dispatch\n File \"C:\Program Files (x86)\OpenERP 7.0-20140217-002618\Server\server\openerp\addons\web\controllers\main.py\", line 570, in index\n File \"C:\Program Files (x86)\OpenERP 7.0-20140217-002618\Server\server\openerp\addons\web\controllers\main.py\", line 98, in db_monodb_redirect\n File \"C:\Program Files (x86)\OpenERP 7.0-20140217-002618\Server\server\openerp\addons\web\controllers\main.py\", line 109, in db_redirect\n File \"C:\Program Files (x86)\OpenERP 7.0-20140217-002618\Server\server\openerp\addons\web\controllers\main.py\", line 90, in db_list\n File \"C:\Program Files (x86)\OpenERP 7.0-20140217-002618\Server\server\openerp\addons\web\session.py\", line 30, in proxy_method\n File \"C:\Program Files (x86)\OpenERP 7.0-20140217-002618\Server\server\openerp\addons\web\session.py\", line 103, in send\nFault: <fault could="" not="" connect="" to="" server:="" connection="" refused="" (0x0000274d="" 10061)\n\tis="" the="" server="" running="" on="" host="" \"localhost\"="" (::1)="" and="" accepting\n\ttcp="" ip="" connections="" on="" port="" 5432?\ncould="" not="" connect="" to="" server:="" connection="" refused="" (0x0000274d="" 10061)\n\tis="" the="" server="" running="" on="" host="" \"localhost\"="" (127.0.0.1)="" and="" accepting\n\ttcp="" ip="" connections="" on="" port="" 5432?\n:="" 'traceback="" (most="" recent="" call="" last):\\n="" file="" \"c:\\\\program="" files="" (x86)\\\\openerp="" 7.0-20140217-002618\\\\server\\\\server\\\\openerp\\\\addons\\\\web\\\\session.py\",="" line="" 89,="" in="" send\\n="" file="" \"c:\\\\program="" files="" (x86)\\\\openerp="" 7.0-20140217-002618\\\\server\\\\server\\\\.\\\\openerp\\\\netsvc.py\",="" line="" 292,="" in="" dispatch_rpc\\n="" file="" \"c:\\\\program="" files="" (x86)\\\\openerp="" 7.0-20140217-002618\\\\server\\\\server\\\\.\\\\openerp\\\\service\\\\web_services.py\",="" line="" 122,="" in="" dispatch\\n="" file="" \"c:\\\\program="" files="" (x86)\\\\openerp="" 7.0-20140217-002618\\\\server\\\\server\\\\.\\\\openerp\\\\service\\\\web_services.py\",="" line="" 359,="" in="" exp_list\\n="" file="" \"c:\\\\program="" files="" (x86)\\\\openerp="" 7.0-20140217-002618\\\\server\\\\server\\\\.\\\\openerp\\\\sql_db.py\",="" line="" 484,="" in="" cursor\\n="" file="" \"c:\\\\program="" files="" (x86)\\\\openerp="" 7.0-20140217-002618\\\\server\\\\server\\\\.\\\\openerp\\\\sql_db.py\",="" line="" 182,="" in="" __init__\\n="" file="" \"c:\\\\program="" files="" (x86)\\\\openerp="" 7.0-20140217-002618\\\\server\\\\server\\\\.\\\\openerp\\\\sql_db.py\",="" line="" 377,="" in="" _locked\\n="" file="" \"c:\\\\program="" files="" (x86)\\\\openerp="" 7.0-20140217-002618\\\\server\\\\server\\\\.\\\\openerp\\\\sql_db.py\",="" line="" 440,="" in="" borrow\\n="" file="" \"psycopg2\\\\__init__.pyc\",="" line="" 178,="" in="" connect\\noperationalerror:="" could="" not="" connect="" to="" server:="" connection="" refused="" (0x0000274d="" 10061)\\n\\tis="" the="" server="" running="" on="" host="" \"localhost\"="" (::1)="" and="" accepting\\n\\ttcp="" ip="" connections="" on="" port="" 5432?\\ncould="" not="" connect="" to="" server:="" connection="" refused="" (0x0000274d="" 10061)\\n\\tis="" the="" server="" running="" on="" host="" \"localhost\"="" (127.0.0.1)="" and="" accepting\\n\\ttcp="" ip="" connections="" on="" port="" 5432?\\n\\n'="">\n", "fault_code": "could not connect to server: Connection refused (0x0000274D/10061)\n\tIs the server running on host \"localhost\" (::1) and accepting\n\tTCP/IP connections on port 5432?\ncould not connect to server: Connection refused (0x0000274D/10061)\n\tIs the server running on host \"localhost\" (127.0.0.1) and accepting\n\tTCP/IP connections on port 5432?\n", "type": "server_exception"}}

thanks

The application and the database are running under on the same host machine?

Rafael Reuber
on 2/18/14, 1:11 PM
0
fabio
On 2/19/14, 7:34 AM

I had to start a new server, thank a lot for your help

0
Rafael Reuber
On 2/18/14, 1:08 PM

Try disable your windows firewall. If your database are running on another host machine the postgres could be configured to avoid external connections. In these case you could try this:

1) Create a backup for C:\Program Files\PostgreSQL\9.1\data\pg_hba.conf;

2) Edit the file C:\Program Files\PostgreSQL\9.1\data\pg_hba.conf;

3) Change the line with this content: host alll all 127.0.0.1/32 to host all all 0.0.0.0/0 md5.;

4) Save the modifications;

5) Restart the server;

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 2/18/14, 12:49 PM
Seen: 2279 times
Last updated: 3/16/15, 8:10 AM