Odoo Help

2

0
3 Answers
1
james_p Thailand
10/6/15, 9:10 PM

In the command line, type

./odoo.py --help

You will see that the syntax should be

--without-demo=WITHOUT_DEMO

In config file, it should be

without_demo=WITHOUT_DEMO
1
Syncordia Ireland
10/6/15, 9:46 PM

--without-demo=all does not work at all. It good to test it with hr module.

It is extreme solution, but works for hr module on Ubuntu 14.04

cd  ${HOME}/odoo 
cp addons/hr/__openerp__.py addons/hr/__openerp__.py.orig
perl -pi -e 's/^(.*)(demo)(.*)/# ${1}${2}${3}/' addons/hr/__openerp__.py
cat addons/hr/__openerp__.py
0
Anass Ahmed Saudi Arabia
10/6/15, 7:18 PM

I think you should recreate your database from scratch (if you use database manager, just don't check the demo data checkbox).

If you use the service from command line (or just have access to the configuration file), so the right syntax is:

without_demo=all

or with the command line:

--without-demo=all
Ask a Question
Writer
Keep Informed
2 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now