Odoo Help


Import products by csv

on 6/7/14, 7:31 AM 2,140 views

The CSV import doesn't work. I use the export to have the model, then i try to impot it and i always have : La prévisualisation de l'import à échoué à cause de : new-line character seen in unquoted field

If i make a new one i always have this error... I use excel to make the file.


How can i do a good file without this new-line character error ???






| 5 4 6
Zagreb | Karlovac, Croatia

there is only 10 kind of people the ones that understand binary ... and others

On 6/10/14, 6:56 AM


The problem is with excell and widows code pages.. 
1. excell is pretty stupid ( does not export UTF-8 , and does not support double quotes on all fields)

Try using LIbre Office or OpenOffice...(no problem openeing .xls files)

 when exporting to csv make sure that you are using recomended export options:

- UTF-8 file encoding format, double qouoted all text fields, and preferably... use it on linux... 
(some users expirience line feed char <CR/LF> problem with files made on windows  )

Defintivly check csv file before importing..  look in product description field

If you need new lines in product description.. dont use newline char ( press enter) ... 
instead use '\n' ..  your description should be in one line of csv .. double quoted...
example: for description: 
"Description line...and some text\nSecond line ofdescription...."     -> Correct format

"Description line...and some text
Second line ofdescription...."  --> format that defintivley produce error on import.. .

hope this helps.. 

Anders Wallenquist
On 6/10/14, 7:03 AM

Libreoffice works fine for me.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)


Asked: 6/7/14, 7:31 AM
Seen: 2140 times
Last updated: 3/16/15, 8:10 AM