Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

import accounts: 'NoneType' object has no attribute 'group'

By
naitsir
on 1/26/14, 1:22 PM 4,694 views

Hi all, I have a big problem, I hope some of you can help me. I'm trying to import this simple data to my accounts C:\fakepath\account.account.png

at the moment to validate OpenERP show me this message

'NoneType' object has no attribute 'group'

the logs show me this

2014-01-26 16:54:12,546 1816 ERROR inicial openerp.netsvc: 'NoneType' object has no attribute 'group' Traceback (most recent call last): File "C:\openerp70\Server\server.\openerp\netsvc.py", line 292, in dispatch_rpc File "C:\openerp70\Server\server.\openerp\service\web_services.py", line 626, in dispatch File "C:\openerp70\Server\server.\openerp\osv\osv.py", line 188, in execute_kw File "C:\openerp70\Server\server.\openerp\osv\osv.py", line 131, in wrapper File "C:\openerp70\Server\server.\openerp\osv\osv.py", line 197, in execute File "C:\openerp70\Server\server.\openerp\osv\osv.py", line 185, in execute_cr File "C:\openerp70\Server\server\openerp\addons\base_import\models.py", line 320, in do File "C:\openerp70\Server\server.\openerp\osv\orm.py", line 1374, in load File "C:\openerp70\Server\server.\openerp\osv\orm.py", line 5336, in convert_pgerror_23502 AttributeError: 'NoneType' object has no attribute 'group' 2014-01-26 16:54:12,651 1816 INFO inicial werkzeug: 127.0.0.1 - - [26/Jan/2014 16:54:12] "POST /web/dataset/call_kw HTTP/1.1" 200 -

I don't know what is the problem, I can create the account from the account form, but I cant import this from a csv file, what is the problem??

another thing I did was add all account columns to file account.account.csv and still not working :(

please help me.

0
Mind And Go
On 6/1/14, 3:06 AM

Hy,

You should have not fill one manadory field. Your logs are not so usefull, have a look above those line, you'll see messages that explain which are missing. Maybe, use the  --log-sql option in your command so that you'll see what's going on in the DB.

Another option could be that the import trying to change the code of an account that already have moves.

Did you try to split your file?

Anyway, better logs would explain you what's wrong

Hope it can help

0
Mehdi
On 5/29/14, 5:37 AM

I do have the same problem.

 

I filled all the required fields : reconcile, code, name, parent_id/id, user_type/id, type, ID, Active, company_id/id, currency_mode.

And I always have the same error message : 'NoneType' object has no attribute 'group'.

 

If anyone has any suggestion plz share.

Thank U.

0
Eva Pinter
On 5/31/14, 11:11 PM

To make sure your format is correct, create an export from within odoo selecting "import compatible" csv format with only one line. Then you can change the external ids to internal ids, then you can try to import the file. This will help you figure out what is missing.

Good luck

0
naitsir
On 1/31/14, 8:08 PM

please!!! somebody can help me with this error??? I can create account one by one, but it is more easy to import from a csv file.

thank you in advance for your help.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 1/26/14, 1:22 PM
Seen: 4694 times
Last updated: 3/16/15, 8:10 AM