Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

2

How to translate terms ?

By
DOMALYS
on 11/4/14, 10:34 AM 3,045 views

Dear all,

I've installed Odoo on a CentOs server, and it's working very fine.

But when I try to print a quote in french (client's language set to french, etc.), most of the terms are well translated but some terms are not, such as "Total Without Taxes" or "Payment Terms". 

I've tried to add a translation or these terms in the configuration (Settings / translation) and synchronized the translation, but it' won't have any effect.

Any idea how to do it ?

Many thanks

PS : I'm aware that the french translation is not finished yet (https://translations.launchpad.net/openobject-addons/8.0/+lang/fr/+index?batch=75&memo=75&start=75). I'm OK to translate myself.

3

Yenthe

--Yenthe--
6686
| 7 7 8
Turnhout, Belgium
--Yenthe--

My Odoo blog: http://www.odoo.yenthevg.com/

My Twitter: https://twitter.com/Yenthe666

Yenthe
On 11/5/14, 3:59 AM

Translation of terms is very easy. I'll give the example with "Total Without Taxes"
1. Go to settings > Application terms > Translated terms
2. Search for the term you're looking for, in this example "Total Without Taxes"
3. You'll now see a record (or multiple) with the original English value and the translation (if there is one).
You can now edit these or add new ones as you wish. In my example I made a translation for English, Flemish and Dutch.
4. When you've translated all the things you want or need you need to synchronize the translations. Do this by clicking on "Synchronize Terms".

Select the language you made a translation for and synchronize. This means if you've translated for Dutch and Flemish you'll need to synchronize the language Dutch AND the language Flemish.
Refresh your page and have a look, it is now translated. (or for example with a new PDF)
Note: If you wish to print a PDF in another language for a customer you will have to place the customer his language on the language you want the PDF to be printed in! This setting is responsible for choosing which language the PDF will have.

While I believe this answers your question I'll also write out the steps about how to translate fields in views.
I'll give the example of the field "Salesperson" when you make a new example.
1. Go to about Odoo and activate the developer mode
2. Navigate to the view where you want to make another translation or term. Then hoover over the fieldlabel where you want to change the name for. For example:

2. Now you know the model (res.partner) and the field (user_id) you can translate it. Go to settings > Application Terms > Translated terms.
3. Search for the term you're looking for, in this example "Salesperson" or alternatively just make a new one.
The first field "Source" is the original text of the label, the second field "Translation value" is the value that you want it to show in your language, field three (translated field) is the name of the model with the name of the field. As you can see in the hoover over the label you have the model res.partner and the field user_id so this would become res.partner,user_id. The fourth field is the language you want to translate for and the fifth field is the kind of text you want to translate. In this example this is a type "field".
So you'll get something like this:

4. Synchronize the translation for the languages you've translated and refresh the page. You're done now.
5. The result:

+1 for clarity and good explanation :)

PY
on 11/5/14, 4:58 AM

Thanks for the +1 PY, thats good to hear! There aren't enough good guides on these kind of topics honestly, they should make some form of help with these basic help tuts.

Yenthe
on 11/5/14, 5:02 AM

I couldn't agree more ! More docs and cleaner code please Odoo team ^^

PY
on 11/5/14, 5:53 AM

Can you help me fix my issues ? https://www.odoo.com/forum/help-1/question/how-to-properly-print-and-translate-custom-reports-67566

PY
on 11/7/14, 5:43 AM

No solution yet, as you can see : http://imageshack.com/a/img910/627/5qzE5N.png Please help !

DOMALYS
on 11/21/14, 7:22 AM

Can you make me a printscreens of the view where you want to translate (and what it shows), a printscreen of the translated values and a bit more extra information? I'll have a look at this then. Because this should work.

Yenthe
on 11/21/14, 11:03 AM

Hello Yenthe. They already are in my post below : http://imageshack.com/a/img673/8076/rkCU0b.png http://imageshack.com/a/img674/8739/48V3bF.png

DOMALYS
on 11/21/14, 11:18 AM

I'll have a look at this tommorow and I'll let you know!

Yenthe
on 11/21/14, 11:20 AM

@Naoli, I had no problems at all to place it in the field. My translations look like this: http://i.imgur.com/OrVmnuR.png My PDF in French: http://i.imgur.com/Nbz7T4x.png My PDF in Dutch: http://i.imgur.com/0thoSqQ.png The only thing I can think of that you're missing is that you did not set the customer/partner his language on French. Odoo bases the translation on the settings of the customer/partner. Your customer his language setting is responsible for in which language there will be printed. For example: http://i.imgur.com/AfsItw0.png

Yenthe
on 11/22/14, 10:04 AM
1
DOMALYS
On 11/7/14, 3:03 AM

Hello,

I'm sorry but it does not work, and it is precisely why I wrote this in my first message ("I've tried to add a translation or these terms in the configuration (Settings / translation) and synchronized the translation, but it' won't have any effect.")

I did search for "Total without taxes" and translated it : http://imageshack.com/a/img673/8076/rkCU0b.png

Then synchronized both french and english languages.

Then I still have the untranslated term  : http://imageshack.com/a/img674/8739/48V3bF.png

Did you fix your issue ? If yes, can you explain us how ?

PY
on 11/12/14, 4:37 AM

No, nothing changed...

DOMALYS
on 11/12/14, 1:30 PM

Same here, I'm having an issue with translating this exact term, "Total Without Taxes". If you found a solution, please enlight us.

Danijel
on 11/17/14, 7:17 AM

Still no luck :-( Did someone find a solution ?

DOMALYS
on 11/19/14, 6:18 AM

I think I have the same problem here. help.

Pascal Tremblay
on 12/14/14, 8:38 PM
0
IRNPS
On 1/8/15, 9:58 AM

I encountered the same issue described by @Naoli and others. I want to refer you all to the following github issues:

https://github.com/odoo/odoo/issues/3033

https://github.com/odoo/odoo/pull/4456

1. As you have already messed up the database you will have to remove the language you are experiencing problems with, either by deleting it from the web language settings panel or by flushing all the associated terms from the ir_translation table in the database (which is easier). 

2. Now reload the fresh language files from the web panel.

3. Now apply the following patch to your odoo installatino https://github.com/odoo-dev/odoo/commit/9d3babf9b0b4af0bdd47eaf52de0f21fc0ae9327.patch, you can do it either manually or by using git apply.

4. Restart odoo-server and refresh/relogin into the odoo web

5. Congrats your odoo language files are fixed and you should be good to go to translate the terms you like the way you see fit without messing them up.

I hope this patch becomes part of the master branch soon, which will spare you the trouble of having to patch the install by hand, but even then I believe you will not be able to avoid flushing your terms table. I hope this helps, and I would appreciate few upvotes to be able to post links in the future.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

4 follower(s)

Stats

Asked: 11/4/14, 10:34 AM
Seen: 3045 times
Last updated: 3/16/15, 8:10 AM