Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

How to start service of multi-instant on ubuntu server

By
jagdish
on 8/12/13, 6:53 AM 3,087 views

Hi

i am working on ubuntu server i have install openerp v7 by Debian package its working fine, But i have to configure other instance for testing purpose, for testing instant i make folder (test) and put openerp Debian package in this folder, I have use different port for my regular instant it use 8069 for testing instant i have user 8080.

i start service for my regular instants sudo /etc/init.d/openerp start and for testing instant i use nohup ./openerp-server command to start service on server it works for some time and stop automatically.

So how can i start service of my both instanst service on server

Thanks

3
Amit Parik (amp)
On 8/13/13, 9:36 AM

Hello Jagdish,

First of all I want to suggest you that please use the launchpad code instead of the debian packages because it will be easier. 2nd thing the complete command is nohup ./openerp-server & . if you are using this will start the services and it will not stop until you stopped the server. So as per my opinion please check the parameter again it will definitely works.

About your 2nd point for multiple instance the best way is as follow. Create 2 different user i.e openerp1, openerp2. download the code for both the user. Create 2 superuser on postgres, openerp1 and openerp2. Alter the role for both then start the openerp server with different port via --netrpc-port=8090 --xmlrpc-port=8091 (You can also assign the host name, So you can use directly that url) . Then it will works great and your 2 different instance will be created.

If your services will be stop after sometime as you specified then do the one thing create the python script for that and it will run the openerp-server directly . So when your server will stop it will check auotmatically and start openerp services again. Here also you have to start your script with nohup command i.e nohup python script.py &

Thank You and hope this will helpful for you!

Thanks for the answer amp

jagdish
on 8/13/13, 9:49 AM
1
Pinakin Nayi (pna)
On 8/13/13, 9:52 AM

Hello,

I think there is one more way of proxy that may be useful to you.

First of all configure Apache sever to use , Now, just go to /etc/apache2/sites-available/ and there create own file like test(without extension) and in it add code like (you can also biferagate different port here) pastebin.com/7yYkMvmi

  • Now, disable default >sudo a2dissite 000-default
  • And enable your own by > sudo a2ensite test

Now, finally restart your apache server by >sudo /etc/init.d/apache2 restart

  • > sudo nano /etc/hosts

Now, when you run your openerp server you can use following command: ./openerp-server --addons-path=../addons/,../web/addons --proxy-mode

From browser : test:8069/

So, its work fine.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 8/12/13, 6:53 AM
Seen: 3087 times
Last updated: 3/16/15, 8:10 AM