Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

How to set up an incoming email server for an user?

By
Juan Formoso
on 5/11/15, 5:30 AM 977 views

I'm trying to configure an incoming mail server for the user admin. This user has the next account: myaddress@mydomain.com.

I did the next steps:

1. Configuration > Configuration > General Settings, section domain alias, I turned it to mydomain.com.

2. Configuration > Users > Users, I selected admin user and went to his Preferences tab. I set his messaging alias to myaddress.

3. I went to Configuration > Technical > Incoming Mail Servers, and created a new one with the next settings:

  • Name: My IMAP server for admin

  • Server type: IMAP server

  • Server name: my_imap_server@mydomain.com

  • Port: 993

  • SSL/TLS: True

  • User: myaddress@mydomain.com

  • Password: pwd_of_my_account

Then I clicked on Test & confirm and there were no errors.

Even I went to Configuration > Automation > Scheduled Actions, and edited the Fetchmail service row, setting the attributes Interval Number to 1 and Interval Unit to Minutes in order to check if there are incoming mails each minute.

It worked perfectly. I was receiving the emails sent to myaddress@mydomain.com in Odoo Messaging Inbox, apart from in the webmail.

Now I copied this configuration on other computer, and it's not working. Any hint of what could be happening?

EDIT

I've realized that there are several computers in which this is working fine and other ones in which not. The difference between the first ones and the second ones is that when I click on Fetch now (in the incoming mail server configuration), in the first ones everything is OK and the second ones are giving me an error:

odoo error: command CLOSE illegal in state AUTH, only allowed in states SELECTED

I've read in other post (https://www.odoo.com/fr_FR/forum/help-1/question/incoming-email-imap-ssl-fetch-mail-error-67956) that may be it could be solved changing the port 993 to 143, but when I do that, I get the next error (in all the computers, both which were working and not):

Connection test failed! Here is what we got instead: 101 The network is unreachable.

0
Juan Formoso
On 5/13/15, 4:17 AM

I found the problems:

1. The module fetchmail_attach_from_folder. Only the computers which were not working had this module installed. When I uninstalled it from all of them, they started to work.

2. The module website_mail: this module, when it's installed, is giving problems of different kinds. For example, in a few computers the scheduled action fetchmail service stops working, so the received emails don't arrive to the inbox automatically. It's necessary to go to the incoming mail server and click on Fetch now to receive the emails. In other computers is even worse, because even clicking on Fetch now, the emails never arrive to the inbox.

I can uninstall the first module with no problem, but I need to keep the second one. I don't know how can I solve this, but I guess I should ask this in other post.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 5/11/15, 5:30 AM
Seen: 977 times
Last updated: 5/13/15, 4:18 AM