Odoo Help

0
2
grayson
On 7/8/15, 9:09 AM

I got an answer through the community mailing list that helped.

(From Martin Trigaux)

In version 8, it should be the salesperson set on the partner creating the order. If there is no sales person, then it fallback on the administrator. If you wish to set another one, you should look into setting a default salesperson to the partners created.

In master version (future v9), it has changed and will now be the salesman specified on the website configuration.

Martin

1
Avatar

Serpent Consulting Services Pvt. Ltd.

--Serpent Consulting Services Pvt. Ltd.--
Serpent Consulting Services Pvt. Ltd.
http://www.serpentcs.com
4790
| 6 6 8
Gandhinagar, India
--Serpent Consulting Services Pvt. Ltd.--

Serpent Consulting Services Pvt. Ltd. is an Official Odoo Partner, working on Odoo ever since 2007, experience of 11+ years and witnessed the growth of Odoo.

We are a team of 80+ experts on various verticals. Our portfolio of products can be seen at http://www.serpentcs.com and http://www.serpentcs.in

Our Expertise and Services:

  • Odoo Support

  • Odoo Development

  • Odoo Training

  • Odoo Migration

  • Odoo Implementation

  • Odoo Consulting

Our 290+ Apps on Appstore : https://apps.odoo.com/apps/modules/browse?author=Serpent Consulting Services Pvt. Ltd.

Thanks.

Serpent Consulting Services Pvt. Ltd.
On 7/8/15, 7:01 AM

Dears,

Techncally, you must override the sale_get_order() method written under the website_sale module and here you can manage to get the ID of the salesman.

Here, if you plan to set the salesman per company for your ecommerce store, you may add up the salesman field inside the company configuration.

Thanks.

0
Carlos A García
On 10/9/18, 5:54 PM

For me in Odoo 8 works this:

Settings/Users/Public user, configure inside the res.partner associated to this user the Salesperson you want to show by default in sales.orders from Web Site. If this field left blank, the Administrator is used instead by default.

0
Jakob Skurdal
On 10/9/17, 6:19 PM

Hi, using Odoo 10c. I have set default SP in website admin, on customer and tried using the set defaults in dev mode. Still, when weborder is made, I get 2 notifications. First, one that tells me a new order is made, with correct sp, and right after a new notification telling med sp is set to admin. What am I missing?

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 6/29/15, 7:06 PM
Seen: 2138 times
Last updated: 10/9/18, 5:54 PM