Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

2

How to remove error "could not get content for /saas_trial/static/css/demo.css defined in bundle 'web.assets_backend'" after hosted DB import to VMS?

By
JonGillibrand
on 2/24/15, 1:22 PM 5,737 views

Hi guys ,
I hope you can help.

I recently took a backup of our odoo installation hosted on odoo.com and uploaded it to a new odoo instance on rosehosting vps. Since I have done that we get the following error shown in a yellow bar at the top of all the backend pages:

"could not get content for /saas_trial/static/css/demo.css defined in bundle 'web.assets_backend"

Everything else seems to work ok, I'm just concerned that there is something thinking this is still a hosted config which could cause problems further down the track. I haven't had time to test every option that odoo has to make sure that nothing else is affected.

 

 

Stephan, That worked, thank you so much! Ill update this thread as it seems to be the only one relating to this and its getting a lot of traffic judging by my gamification badges from the forum!

JonGillibrand
on 2/24/15, 7:23 PM
5
Stefan Rijnhart
On 4/14/15, 3:44 PM

On a SAAS database that I recently migrated to self hosting, I noticed this as well. The view that includes the css belongs to a module called 'saas_trial' according to the ir_model_data table. This module is not included in the core Odoo distribution. Moreover, the module state was set to 'uninstalled'. The css view and some other minor data entries imply that the module was sort of ripped out of the installation and set to uninstalled manually instead of through the uninstallation process.

I was able to solve this using the following SQL query:

update ir_module_module set state = 'to remove' where name = 'saas_trial'; 

Next, I went into menu Settings -> Modules and clicked Apply scheduled upgrades. This removed the remaining data of this module, including the view that attempts to load the missing css.


Thanks. This also worked for me!

Bista Solutions US, Ray Carnes
on 5/11/15, 4:58 PM
0
Shawn Varghese
On 2/24/15, 3:20 PM

This maybe because the web.url property has not been correctly defined and the CSS cannot be fetched as a result.

 

1) Go to Settings/Users/Users

2) Click on your user and under the Access Rights tab, enable Technical Features

3) Refresh the page and the scroll down the left-meu bar. You should see 'Parameters'

4) Select System Parameters'

5) You will see a web.base.url parameter. It should ideally have the server's IP address and port like "http://192.168.2.30:8069. If not, set it, and restart the server and check again.

In my case, I had to update the module as well. So maybe you can try updating your saas_trial module.

6) If this does work, you can create a web.base.url.freeze system parameter and set it to True. The web.base.url.freeze parameter is to lock the url so it does not change.

Let me know if this doesn't work.

Check this link out for a detailed discussion.

https://github.com/odoo/odoo/issues/1105

 

 

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 2/24/15, 1:22 PM
Seen: 5737 times
Last updated: 8/24/16, 9:43 PM