Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


How to install OpenERP modules on Synology NAS that use PostgreSQL procedural languages like plpgsql.so?

on 3/29/13, 5:49 PM 14,029 views

Ok so we have setup OpenERP on our DS213 and everything works fine until we start installing certain Modules. Two that we are having particular problem with are: OpenErpPlm & project_timesheet

We could almost live without OpenErpPlm for now (which allow our 3D data to be managed using OpenERP) but the "project_timesheet" is more critical as it is needed for our engineers to clock their time per tasks and have that time be available in the HR & accounting modules to issue invoices.

The problem seem to reside in the fact that the PostgreSQL database installed on the Synology is missing a number of procedural languages that normally come standard with a PostgreSQL install.

This is the error we get in OpenERP when trying to install those modules: "OperationalError: could not load library "/usr/syno/pgsql/lib/plpgsql.so": /usr/syno/pgsql/lib/plpgsql.so: cannot open shared object file: No such file or directory"

I'd love to know of a workaround to fix this.

Thanks in advance!





| 5 6 9
Lisse, Netherlands
End-User. Installed 6.1.1 on a DS412+, DS211+ and DS113J Synology NAS. Reference installation on Ubuntu 12.04/Samsung Notebook. 12-03-2013 In production for Suppliers and Customers, adresbook. 7 small companies. Testing accounting, document management, import and export. Too much showstoppers I haven't fixed at this moment. 06-05-2013 little progress. Migration to v7 impossible because of missing Dutch localisation modules. What I see working is nice, so further testing and asking. Start testing products and warehouse. Happy with this forum and the community.
On 3/30/13, 6:33 AM

I do not have the answer and I am not an expert but maybe I can help you in finding the answer. Testconfiguration:

  1. Testsystem Synology DS112J with DSM4.1 build 2626
  2. OpenERP 6.1.1-012 (I don't know the builnummer of OpenERP, I hope I find out once how to retrieve this)
  3. Python

  4. PostgreSQL Database Server 8.3.11.

    First step I usualy take is close all other services on the Synology. Log in as administrator. Go to packages
    and stop all excluding Python and OpenERP. This is because there are a lot of services on Synology that use Postgres and Pgsql which can conflict OpenERP / Postgres / pgsql. Stop and start openERP and try to do what
    failed again. If it is ok, you know a lot .... If it is not ok you can restart all other packages.

Second step is I started Itari's admin tool - this is a must have tool for in depth managing a Synology and it is free - and I looked for libraries.

Findings: In user/syno/pgsql there are no libraries. In usr/ lib ->/lib there are symlinks with libraries. However I didn't see plpgsql.so.

Next Steps:

  • You could check on a Ubuntu 12.04 reference system (you can use a virtual machine for this) the locations of the libraries and if more libraries are missing.
  • Copy in the missing libraries from the Ubuntu configuration or from internet to the synology.
  • You can also check the configuration files on Synology where libraries are expected to be.
  • If the copy doesn't work you need to install plpgsql.so the formal way as described here: http://www.postgresql.org/docs/8.2/static/xplang-install.html For synology a variant on this can be needed.

I am very interested if this is of help for you. And if you find a solution please report your steps in detail as an answer on your own question.

I have posted a lot of the configuration parameters of OpenERP 6.1.1-011 on a synology DS412+: http://forum.synology.com/enu/viewtopic.php?f=184&t=56373

Added 10 April 2013:

There is also an other method you can use to add the missing libraries with apt-get. Therefor you need to install Debian Chroot on your Synology.

This software is available from the Synology Community:

Add in your Package Center packetsources:

"http://packages.synocommunity.com" (you can't click on this, it is only for adding in the field on the synology.). You can click on: http://www.synocommunity.com/

Thanks for all the effort to help and also for the nice OpenERP config post you have on the Synology forum! So I did try to copy the library files (plpgsql.so and others) from a working Ubuntu build but the problem remains. As you already guessed those libraries can not be installed withing the Synology environment. So someone would have to crank out an ipkg for it to run. I couldn't find one online and it is a little over my head to do since I have never attempted such a thing.

on 4/1/13, 8:54 PM

Please vote my answer up. I think it is an ommission in the OpenERP package Synology present us. I think it is best to inform them about this issue so can make an update of the system. My findings with Synology support are very good. The only thing it is very important to describe everything is detail and let contact management pass it to their development team.

on 4/2/13, 4:51 AM

OK, so I did reach out to Synology and they were indeed responsive and gave me a link to a page where I could submit a feature request to their development team. I am keeping my fingers crossed that this will indeed make it to a future update. I would still love to know if there is a workaround in the mean time since it will probably be months before a new DSM release is out. If there are ipkg expects reading this, please, please, please help us out :-)

on 4/2/13, 1:59 PM

I did the same and asked also other things for improvement. I don't think the solution is dependent on a new DMS. If they are willing to solve this it could be in an update of python, openerp or a minor update of DMS. For me it do not have priority, but if you have a solution or workaround of your own please make a detailed post of it.

on 4/3/13, 5:38 AM

Thanks! I'll definitely post a step-by-step solution if/when I find one.

on 4/3/13, 5:48 AM

Maybe this alternative can be of help: http://www.mertymade.com/syno/

on 4/3/13, 2:54 PM

Looks like I have some reading to do ;-) Thanks for the link! I had not heard of this page before.

on 4/3/13, 3:12 PM

I have installed 7.0 on Synology. Any updates form you?

on 7/20/13, 6:19 AM

I noticed Synology added OpenERP 7.0 to their list of available applications a few days back, which is great! Unfortunately my Windows installed 7.0 database doesn't want to import into the Synology :( I also tried to install the "project_timesheet" module in our freshly installed OpenERP 7.0 on Synology and still get an error. This time it's: ProgrammingError: syntax error at or near "with mu"

Jean-Michel Thiers
on 7/20/13, 3:08 PM

It is important you use the same python routines and additional scripts. I do not know if this is the problem in your situation. In the 6.1.1 version on synology there were a lot of things missing which gives errors and / or missing functionality. See also my last post in http://forum.synology.com/enu/viewtopic.php?f=184&t=62754&start=15

on 7/22/13, 1:04 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 3/29/13, 5:49 PM
Seen: 14029 times
Last updated: 3/16/15, 8:10 AM