Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

13

How To Install Odoo from Github on Ubuntu 14.04 For Testing Purposes Only (ie. not for production)

By
Luke Branch
on 5/21/14, 1:54 AM 125,736 views

Due to recent changes in the base module structure this step by step guide is now out of date. I'd recommend doing the following at a terminal:

wget https://raw.githubusercontent.com/lukebranch/openerp-install-scripts/master/odoo-saas4/ubuntu-14-04/odoo_install.sh
sudo sh odoo_install.sh

this will run a script (forked from Andre Schenkel's original script here - https://github.com/aschenkels-ictstudio/openerp-install-scripts) that will run the process for you. I will update the step by step instructions below when I can find time.

I have found the following steps to work for installing Odoo v8 from the github repository:

https://github.com/odoo/odoo

1) Install Ubuntu 14.04
2) open a terminal 
3) sudo apt-get update
4) sudo apt-get install git
5) apt-get install postgresql
6) sudo su - postgres -c "createuser -s openerp" 2> /dev/null || true
7) sudo apt-get install python-dateutil python-feedparser python-gdata python-ldap \ python-libxslt1 python-lxml python-mako python-openid python-psycopg2 \ python-pybabel python-pychart python-pydot python-pyparsing python-reportlab \ python-simplejson python-tz python-vatnumber python-vobject python-webdav \ python-werkzeug python-xlwt python-yaml python-zsi python-docutils \ python-psutil wget python-unittest2 python-mock python-jinja2
8) sudo apt-get install python-dev libpq-dev
9) sudo apt-get install poppler-utils
10) sudo apt-get install python-pdftools
11) sudo apt-get install antiword
12) sudo mkdir /opt/odoo
13) cd /opt/odoo
14) sudo git clone https://github.com/odoo/odoo.git
15) cd ~/
16) wget http://gdata-python-client.googlecode.com/files/gdata-2.0.18.tar.gz
17) tar zxvf gdata-2.0.18.tar.gz
18) cd gdata-2.0.18/
19) sudo python setup.py install
20) cd /opt/odoo
21) sudo apt-get install python-setuptools python-pybabel
22) sudo python setup.py install
23) sudo cp /opt/odoo/install/openerp-server.conf /etc/openerp-server.conf
24) sudo pico -w /etc/openerp-server.conf

delete default settings and add the following:

[options]
; This is the password that allows database operations:
; admin_passwd = admin
; db_host = False
; db_port = False
; db_user = postgres
; db_password = admin

[options]
## Server startup config - Common options
# Admin password for creating, restoring and backing up databases
admin_passwd = admin
# specify additional addons paths (separated by commas)
addons_path = /opt/odoo/addons
## XML-RPC / HTTP - XML-RPC Configuration
# disable the XML-RPC protocol
xmlrpc = True
# Specify the TCP IP address for the XML-RPC protocol. The empty string binds to all interfaces.
xmlrpc_interface = 127.0.0.1
# specify the TCP port for the XML-RPC protocol
xmlrpc_port = 8069
# Enable correct behavior when behind a reverse proxy
proxy_mode = True
## XML-RPC / HTTPS - XML-RPC Secure Configuration
# disable the XML-RPC Secure protocol
xmlrpcs = True
# Specify the TCP IP address for the XML-RPC Secure protocol. The empty string binds to all interfaces.
xmlrpcs_interface = 
# specify the TCP port for the XML-RPC Secure protocol
xmlrpcs_port = 8071
# specify the certificate file for the SSL connection
secure_cert_file = server.cert
# specify the private key file for the SSL connection
secure_pkey_file = server.pkey
## NET-RPC - NET-RPC Configuration
# enable the NETRPC protocol
netrpc = False
# specify the TCP IP address for the NETRPC protocol
netrpc_interface = 127.0.0.1
# specify the TCP port for the NETRPC protocol
netrpc_port = 8070
## WEB - Web interface Configuration
# Filter listed database REGEXP
dbfilter = .*
## Static HTTP - Static HTTP service
# enable static HTTP service for serving plain HTML files
static_http_enable = False 
# specify the directory containing your static HTML files (e.g '/var/www/')
static_http_document_root = None
# specify the URL root prefix where you want web browsers to access your static HTML files (e.g '/')
static_http_url_prefix = None
## Testing Group - Testing Configuration
# Launch a YML test file.
test_file = False
# If set, will save sample of all reports in this directory.
test_report_directory = False
# Enable YAML and unit tests.
test_disable = False
# Commit database changes performed by YAML or XML tests.
test_commit = False
## Logging Group - Logging Configuration
# file where the server log will be stored (default = None)
logfile = /var/log/openerp/openerp-server.log
# do not rotate the logfile
logrotate = True
# Send the log to the syslog server
syslog = False
# setup a handler at LEVEL for a given PREFIX. An empty PREFIX indicates the root logger. This option can be repeated. Example: "openerp.orm:DEBUG" or "werkzeug:CRITICAL" (default: ":INFO")
log_handler = ["[':INFO']"]
# specify the level of the logging. Accepted values: info, debug_rpc, warn, test, critical, debug_sql, error, debug, debug_rpc_answer, notset
#log_level = debug
log_level = info

25) sudo su postgres -c "createuser -s <your_ubuntu_username_here>"    Please simply insert your own ubuntu username in place of <your_ubuntu_username_here>
26) sudo ufw allow 80
27) sudo ufw allow 8072
28) sudo ufw allow 8069
29) cd /opt/odoo
30) ./openerp-gevent -c /etc/openerp-server.conf
31) Go to your browser and type in 127.0.0.1:8072 (this will run in 'Gevent' mode and allow you to use the live chat functionality)
32) Go back to terminal and type ifconfig to find your ubuntu install's IP address on the local network
33) Go to another computer and open a browser to the following page: http://<your-ubuntu-install's-ip-address-here>:8072

While this is by no means a secure or production ready install, it has allowed me to install a copy of the Odoo v8 (alpha) from github for testing. There are probably better ways to do this and I welcome any comments on how to change these steps to improve the process.

I am simply putting this out there for anyone who is looking to get a demo installation setup for testing, as I was not able to find a complete set of instructions myself that worked.

I have copied selected information from the following helpful blog post here:

http://www.simplerp.it/openerp/sezioni/technolab/item/307-installazione-di-openerp-8-su-debian-7/307-installazione-di-openerp-8-su-debian-7

7

swapnil wagh

--swapnil wagh--
1559
| 6 5 8
Pune, India
--swapnil wagh--

My name is Swapnil A. Wagh. I studied Master Of computer Science and work as a Software Engineer. I’m a technology enthusiast and always eager to learn new and exciting technologies. I’m constantly looking for innovative solutions to age-old problems that push the limits of what we conceive to be possible.

swapnil wagh
On 5/23/14, 7:04 AM

Odoo installation on ubuntu is similary to its old version there is no difference in installation of odoo v8 and odoo v7. 

Check out this blog post for more information http://tinyurl.com/njktd9h

3

Openies Services

--Openies Services--
925
| 2 2 4
Vadodara, India
--Openies Services--

We provide Odoo Services.

Contact us on : contact@openies.com

Openies Services
On 8/28/15, 6:00 AM

Agreeing with previous answer, Odoo v9 installation is same like older version. additionally you need to install node-less

Here is our fresh how to guide to Install Odoo v9 in ubuntu 14.04 LTS 

Hope this will be more helpful in development environment. 

2

Luke Branch

--Luke Branch--
1531
| 6 7 8
Mui Wo, Lantau, Hong Kong
--Luke Branch--

...

Luke Branch
On 7/9/14, 2:20 AM

I've made some minor additions/modifications to Andre's very useful script to add support for wkhtmltopdf and openerp-gevent mode among a few other things:

Modified Script: https://github.com/lukebranch/openerp-install-scripts/blob/master/odoo-saas4/ubuntu-14-04/odoo_install.sh

Andre's Original Script: https://github.com/aschenkels-ictstudio/openerp-install-scripts/blob/master/odoo-saas4/ubuntu-14-04/odoo_install.sh

this version of the script is designed for Ubuntu 14.04 64 bit, however if you want to run it on an Ubuntu 14.04 32 bit machine simply change line #93 to the following:

sudo wget kaz.dl.sourceforge.net/project/wkhtmltopdf/0.12.1/wkhtmltox-0.12.1_linux-trusty-i386.deb

This script is designed to run on a clean install of Ubuntu 14.04 and should install all required dependencies (as far as I am aware) and pull the design-themes branch from github.com/odoo/design-themes. I believe the Zen theme is currently working with the v8.0 branch, however I have not managed to get the other themes working yet (ie. theme_clean and theme_gourmand).

by default this script is set to run the server in openerp-gevent mode (running on port 8072), however if you would like to run the script in openerp-server model (running on port 8069) just change line #25 to the following: OE_SERVERTYPE="openerp-server"

Luke Branch
on 7/9/14, 2:24 AM

Good evening Luke! Great script BTW! We have been using an older version of OpenERP on a different server for quite some time now and would like to install an older version of openerp on a new server. Is there any way we can modify your script to install an older version? Specifically Version 8.0dev-20140407-230101 I look forward to hearing from you. Thanks in advance!

Marty Langen
on 9/23/14, 9:48 PM

@Marty Langen, Thanks for your message, although it's important to mention all credit goes to Andre Schenkel's (www.schenkels.nl) for the original script, I simply forked it and modified and expanded on it to suit my own requirements (openerp-gevent mode, extra packages, modules, etc.). Technically if you simply modify line #28 of the odoo_install.sh after you have downloaded it to your machine and change the following line: OE_VERSION="8.0" to: OE_VERSION="7.0" this should install an earlier branch (eg. version 7.0) with all necessary requirements. You may also find you'll need to modify line #25 from: OE_SERVERTYPE="openerp-gevent" to: OE_SERVERTYPE="openerp-server" This should all be run on an Ubuntu 14.04 install (as certain packages are designed specifically for 14.04 - eg. wkhtmltopdf) however slight modifications could be made to work with earlier Ubuntu versions. Rolling back to a different commit (eg. 8.0dev-20140407-230101) is another story. I have not yet needed to do this myself, however once I figure out how to do this I will post back here. Do you have a copy of the git SHA that was used when you downloaded the branch?

Luke Branch
on 9/23/14, 10:30 PM

you may be able to find this by going to the Odoo directory and doing a: git log and searching back through the log for the exact SHA of the commit on the date you did a git clone or git pull of the 8.0 (RC1) branch, for example: commit 734713bc047d87bf7eac9674765ae793478c50d3 where: 734713bc047d87bf7eac9674765ae793478c50d3 is the SHA once you have the SHA it may be possible to roll your files back to their state at that commit. Please post back with what you find so that others in the community can benefit from your experience. I think this may be useful for those that we developing and testing on the earlier (pre-stable release) 8.0 branch to allow them to restore and export their database backups among other things.

Luke Branch
on 9/23/14, 10:35 PM
2

Atul Kumar jain

--Atul Kumar jain--
914
| 5 3 7
Indore, India
--Atul Kumar jain--

.

Atul Kumar jain
On 6/19/14, 4:32 AM

for odoo installation prefrer this article

 

http://netbeam.in/blog/install-odooopenerp-on-linuxubuntudebian/

1
Rami Talat
On 11/8/14, 7:40 AM

Dear Luke, Thanks a lot for your great effort, but I tried this script many time with no use to get odoo started. I tried to start odoo after runnning this script with ni use also.
N.B. I use a clean ubntu 14.04 32-bit every time before running this scipt.
 

Can you help me?
 

Hi Rami, Please open an issue on github here: https://github.com/lukebranch/odoo-install-scripts/issues Is there any particular reason you are using Ubuntu 14.04 32 bit? I'd recommend reinstalling your system with the 64-bit version if your hardware can handle it, as you will get much better performance. The script is geared towards Ubuntu 14.04 64-bit, and some of the dependencies are 64-bit so I think this may have something to do with your issues.

Luke Branch
on 11/9/14, 10:20 PM

I'm using 32-bit Ubuntu, because my PC's BIOS doesn't support 64-bit (while is it 64-bit Windows 8.1), so I can't run 64-bit VMs, and therefore can't support it seamlessly. That's the reason :(

Rami Talat
on 11/13/14, 12:18 PM

@Rami, please edit /etc/odoo-server.conf and change the following line: log_level = info to: log_level = debug and restart your machine. Then provide me with a copy of the contents of the file by adding it to a gist on github.com (or something similar like pastebin). I think it is likely due to some 64 bit packages in the script that are causing conflicting issues, however i'll take a look at your debug file and see how I can make the script both 32bit and 64bit compatible.

Luke Branch
on 11/14/14, 1:00 AM

Luke, First off, I'd like to thank you very much for your help and quick replies. About the /stc/odoo-server.conf file i did what i understood and here is the gist: https://gist.github.com/ramitalat/1d34af340f16216d402a , I'm waiting your help.

Rami Talat
on 11/14/14, 4:07 AM

@Rami, Thanks for the gist, please now provide me with a copy of the following file as another gist: /var/log/odoo/odoo-server.log this will provide me with the details i need for troubleshooting what the issue is that is making the Odoo service unable to start.

Luke Branch
on 11/14/14, 4:33 AM

Surprise!!! there's nothing under /var/log/odoo Please advice me, should I install my VM again for the fifth time?!!

Rami Talat
on 11/14/14, 10:53 AM

Luke, I installed a new ubuntu 14.04.1 32-bit, then I tried this script again (by the way the wkhtmltopdf here is for 64-bit), but I noticed some errors while running the script. I just captured the end of the file in this gist; https://gist.github.com/ramitalat/bf9c86ca3e7971909ac8 please help. the

Rami Talat
on 11/15/14, 3:42 AM

@Rami, I'm currently working on modifying the script to allow compatibility with 32-bit Ubuntu. You can download the 32-bit wkhtmltopdf from the sourceforge repository, however this is not why your odoo will not start. Please try the following: 1) sudo su odoo 2) cd /opt/odoo/odoo-server 3) ./openerp-gevent -c /etc/odoo-server.conf 4) visit your computer's ip + odoo's port number in a browser on your local network (eg. 192.168.1.123:8072) 5) let me know the output of the errors that Odoo-server gives you. I'm working on getting things running on Ubuntu 32 bit on a local instance of my own, but this will take me some time to work though.

Luke Branch
on 11/15/14, 3:47 AM

@Rami, forget the above for now. Provision a completely fresh install of Ubuntu 14.04 32 bit and then do a fresh wget of the script (i've just made some changes). Run the script through to the finish and reboot and let me know if you can access Odoo. If you run into any errors please comment back with a gist like you did above and i'll take a look.

Luke Branch
on 11/15/14, 3:50 AM

Luke, I used this fork from your script (my own forkm just about wkhtmltopdf)m here you are; https://gist.github.com/ramitalat/1a34e7a5ac11da4b4fe3 . Now, everything is working fine !!!! Great work. and what is more great is your help, thx.

Rami Talat
on 11/15/14, 7:34 AM

By the way, won't you change your phrase "For Testing Purposes Only (ie. not for production)" after Odoo 8?

Rami Talat
on 11/15/14, 9:19 AM

Hi Rami, Glad to hear it's working for you now. I believe there were some issues with the most recent updates I made to the script and those changes have now been removed. The script should work on both 32 bit and 64 bit machines (with the exception of wkhtmltopdf). When I can find a few minutes i'll add an if else statement in the script for determining which wkhtmltopdf version to use for the script. In regards to referring to testing purposes on the post, it's important to note that this script does not setup your server or Odoo as production-ready. There are many security considerations to be taken into account (both for server security and Odoo security) before you can consider using Odoo in production with a public-facing login/website.

Luke Branch
on 11/15/14, 10:47 PM

Dear Luke, I used your script many times before, but now I tried it more than 7 times and get failed every time!!! Can you please find the problem?

Rami Talat
on 1/5/15, 10:16 AM

@Rami, I'll need you to provide more details about that. Please post all issues with the script on the script's github.com issues page here: https://github.com/lukebranch/odoo-install-scripts/issues This is the best way to get assistance with issues you are having with the script and will make sure that any bug reports are handled through the proper channels.

Luke Branch
on 1/7/15, 2:23 AM
1

I would like to say thanks to Luke, for his greit job. His script 

installed for me Odoo V8 in a clean Ubuntu machine on Amazon Web Services.

I have run the next commands provided by Luke:

1) sudo rm -rf odoo_install.sh 2) wget https://raw.githubusercontent.com/lukebranch/openerp-install-scripts/master/odoo-saas4/ubuntu-14-04/odoo_install.sh 3) sudo sh odoo_install.sh

 

 

-Before succeding with the Luke Script, I had problems Installing Odoo V8 in Amazon Web Services with these two procedures:

1.-  I had problems with this link http://netbeam.in/blog/install-odooopenerp-on-linuxubuntudebian/

when installing Postgres in my Ubuntu machine on Amazon Web Services

2.- My problems regarding the  below procedure,

were with the step 22) sudo python setup.py install /

so I didn't finish the installation.
 

1) Install Ubuntu 14.04
2) open a terminal 
3) sudo apt-get update
4) sudo apt-get install git
5) apt-get install postgresql
6) sudo su - postgres -c "createuser -s openerp" 2> /dev/null || true
7) sudo apt-get install python-dateutil python-feedparser python-gdata python-ldap \ python-libxslt1 python-lxml python-mako python-openid python-psycopg2 \ python-pybabel python-pychart python-pydot python-pyparsing python-reportlab \ python-simplejson python-tz python-vatnumber python-vobject python-webdav \ python-werkzeug python-xlwt python-yaml python-zsi python-docutils \ python-psutil wget python-unittest2 python-mock python-jinja2
8) sudo apt-get install python-dev libpq-dev
9) sudo apt-get install poppler-utils
10) sudo apt-get install python-pdftools
11) sudo apt-get install antiword
12) sudo mkdir /opt/odoo
13) cd /opt/odoo
14) sudo git clone https://github.com/odoo/odoo.git
15) cd ~/
16) wget http://gdata-python-client.googlecode.com/files/gdata-2.0.18.tar.gz
17) tar zxvf gdata-2.0.18.tar.gz
18) cd gdata-2.0.18/
19) sudo python setup.py install
20) cd /opt/odoo
21) sudo apt-get install python-setuptools python-pybabel
22) sudo python setup.py install
23) sudo cp /opt/odoo/install/openerp-server.conf /etc/openerp-server.conf
24) sudo pico -w /etc/openerp-server.conf

Thanks

 

 

Hi Javier, glad to hear it has helped you out, but it is worth noting that I was not the original author of that script, I have only modified and expanded on a script written by Andre Schenkel's (http://www.schenkels.nl/2014/07/install-odoo-v8-0-from-github-ubuntu-14-04-lts-formerly-openerp/). I wouldn't recommend using it as is in production, as there is still a fair number of server security measures to take. It is also worth noting that the install you have currently is currently RC1 (release candidate 1) and therefore not the final stable release of Odoo version 8.0. It should be safe to develop on, however I would personally not recommend launching a website or project with it in it's current state (RC1) until the final release of 8.0.

Luke Branch
on 7/11/14, 10:32 AM
1
Kurt Haselwimmer
On 7/11/14, 6:38 AM

You can also get Odoo v8alpha1 (2nd July) up and running on AWS for free if your AWS account is less than a year old - you can qualify for their free usage tier.

Pragmatic have a complete Odoo v8alpha1 stack with ubuntu and postgres/phppgadmin here:- https://aws.amazon.com/marketplace/pp/B00KNO9DYW/ref=srh_res_product_title?ie=UTF8&sr=0-2&qid=1405074711893. It is free also.

I know very little about building from git or running unix systems but have been able to run up 5 instances in the last 12 hours so it is pretty foolproof. The main difficulty seemed in working out how to connect to the instance via ssh after getting it running - you need to follow the instructions carefully to register the .pem key file on your client machine, and use the login 'ubuntu@your.ip.add.on.aws' but after that it seems fine.

I am not affiliated with AWS or Pragmatic, and have already asked the latter to put up a v8RC1 AMI for all us hungry proto-developers.

0
carras
On 7/9/14, 7:58 PM

Hi,

I've try many times to install odoo 8 in Ubuntu 14.04 in several ways but I keep getting the same (following) error. Anyone knows what I'm doing wrong?

Thanks.

 

Traceback (most recent call last):

  File "./openerp-gevent", line 11, in <module>

    openerp.cli.main()

  File "/home/ubuntu/odoo/openerp/cli/__init__.py", line 71, in main

    o.run(args)

  File "/home/ubuntu/odoo/openerp/cli/server.py", line 174, in run

    main(args)

  File "/home/ubuntu/odoo/openerp/cli/server.py", line 139, in main

    openerp.tools.config.parse_config(args)

  File "/home/ubuntu/odoo/openerp/tools/config.py", line 327, in parse_config

    openerp.netsvc.init_logger()

  File "/home/ubuntu/odoo/openerp/netsvc.py", line 136, in init_logger

    resetlocale()

  File "/home/ubuntu/odoo/openerp/tools/translate.py", line 992, in resetlocale

    for ln in get_locales():

  File "/home/ubuntu/odoo/openerp/tools/translate.py", line 960, in get_locales

    lang = locale.getdefaultlocale()[0]

  File "/usr/lib/python2.7/locale.py", line 543, in getdefaultlocale

    return _parse_localename(localename)

  File "/usr/lib/python2.7/locale.py", line 475, in _parse_localename

    raise ValueError, 'unknown locale: %s' % localename

ValueError: unknown locale: UTF-8

Hi Carras, Please copy and paste the contents of the following file from the terminal: /etc/default/locale you can access this file by going to the terminal and typing "sudo pico -w /etc/default/locale" and then typing in your password. The contents should be something like the following (please replace the below with the original): LC_ALL=en_US.UTF-8 LANG=en_US.UTF-8 LANGUAGE=en_US:en Please be advised that you should only do this if you are on a clean Ubuntu 14.04 install, as changing the locale on a machine with other programs you are using on it may cause issues for you. If it is a clean install you should have no problem. After you have saved the above file you should then run the following command: "sudo dpkg-reconfigure locales" after this process has finished you should reboot the machine and try again. If you are unable to get it working I suggest you start again with a fresh install of Ubuntu 14.04 and then run my slightly modified version of Andre Schenkel's install script found here: https://github.com/lukebranch/openerp-install-scripts/blob/master/odoo-saas4/ubuntu-14-04/odoo_install.sh Please post back if it comes to this and I will provide you with instructions on how to download and run the script.

Luke Branch
on 7/9/14, 10:32 PM

How can I execute the script? I've try the following but didn't work: ubuntu@ip-172-31-13-71:~$ sudo sh odoo_install.sh odoo_install.sh: 7: odoo_install.sh: Syntax error: newline unexpected

carras
on 7/10/14, 10:42 AM

Hi Carras, If you have already tried to install Odoo on the machine and you are then trying to run the above script I suggest that you start again with a fresh clean install of Ubuntu 14.04. The above script is designed to be used on a 64 bit machine due to the version wkhtmltopdf in the script. If you are on a 32 bit machine just edit the script and change line number 93 to the following: sudo wget kaz.dl.sourceforge.net/project/wkhtmltopdf/0.12.1/wkhtmltox-0.12.1_linux-trusty-i386.deb Please post back if you have any further issues.

Luke Branch
on 7/10/14, 10:53 AM

Hi Carras, If you have already tried to install Odoo on the machine and you are then trying to run the above script I suggest that you start again with a fresh clean install of Ubuntu 14.04. The above script is designed to be used on a 64 bit machine due to the version wkhtmltopdf in the script. If you are on a 32 bit machine just edit the script and change line number 93 to the following: sudo wget kaz.dl.sourceforge.net/project/wkhtmltopdf/0.12.1/wkhtmltox-0.12.1_linux-trusty-i386.deb Please post back if you have any further issues.

Luke Branch
on 7/10/14, 10:53 AM

I'm on a clean instance in aws Ubuntu 14.04 but I get that error when I try to execute the script. What should I do to execute it? What command do you use? Thanks a lot for helping.

carras
on 7/10/14, 10:57 AM

try the following: 1) sudo rm -rf odoo_install.sh 2) wget https://raw.githubusercontent.com/lukebranch/openerp-install-scripts/master/odoo-saas4/ubuntu-14-04/odoo_install.sh 3) sudo sh odoo_install.sh

Luke Branch
on 7/10/14, 11:09 AM

That's working perfect, thanks a lot my friend!. I saw that is 8.0 branch should I consider it as stable? Cuz I use openerp for my company; do you know how to migrate DB from 7.0 version?

carras
on 7/10/14, 11:55 AM

Hi Carras, I believe the current v8.0 is RC1 (Release Candidate 1). There may be a few iterations before the final release is confirmed. I'd recommend keeping your eye on the odoo facebook page for announcements. In regards to stability from what I understand in v8.0 the database structure and general architecture is now frozen so I believe it is safe to begin developing on the current 8.0 branch. I believe they will only make major revisions if a serious bug/issue is found in any of the release candidates. With that being said, I would not recommend using it in production until you have had a professional with experience with Odoo and server security to make sure your Odoo instance is setup and secured. The script I have provided is just an install script to get you started. It's not recommended for implementing in production until you have implemented and understand the security measures that need to be made before using it in production.

Luke Branch
on 7/10/14, 11:27 PM

Hi Luke, sorry to bother you. I'm using Andre script and yours and I consistently get a 500 error when I tray to create the first DB, I get: "Internal Server Error: The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application." In the log I find: 1.1097 CRITICAL admifinca openerp.modules.module: Couldn't load module auth_crypt 2.1097 CRITICAL admifinca openerp.modules.module: No module named passlib.context How can I solve this? It used to work for me your scripts, I don't know what I miss.

carras
on 9/11/14, 9:38 PM

@carras, There has been some minor changes during the last update to the 8.0 branch that seem to be causing this error. When I have some time to investigate I will update my fork of the script. I think it may be due to an issue with the branch, however i'll report the issue on github and see if it is the script or the update that is causing the issue.

Luke Branch
on 9/11/14, 9:58 PM

Could be something relate with the permissions of the Postgresql user?

carras
on 9/11/14, 10:10 PM

@carras, try the following: sudo pip install passlib and then restart the server. This has resolved the issue in my case. This seems to have been introduced in a recent update, as it seems that the module "Password Encryption" it is now part of the base modules that are installed when a new database is setup. Please write back if there are any other issues you run into and please delete the old odoo_install.sh on your machines and download a fresh version by typing the following at a terminal: wget https://raw.githubusercontent.com/lukebranch/openerp-install-scripts/master/odoo-saas4/ubuntu-14-04/odoo_install.sh and then run according to previous instructions (ie. sudo sh odoo_install.sh)

Luke Branch
on 9/12/14, 1:21 AM
0
Jayson
On 10/16/14, 3:21 AM

Im having Problems in installing this.

Please Help anyone. ?

Traceback (most recent call last):
  File "./openerp-server", line 2, in <module>
    import openerp

 File "/home/openerp/odoo/openerp/__init__.py", line 78, in <module>
    import service

File "/home/openerp/odoo/openerp/service/__init__.py", line 28, in <module>
    import server

File "/home/openerp/odoo/openerp/service/server.py", line 10, in <module>
    import psuti

Can anyone help me to solve this problem.. ?

 

 

 

 

@Jayson, it looks as if you may have some missing dependencies. Did you use the install script here on a clean Ubuntu 12.04 or 14.04 system?: https://raw.githubusercontent.com/lukebranch/odoo-install-scripts/master/odoo-saas4/ubuntu-14-04/odoo_install.sh In that the directory Odoo is installed in is inside /home/openerp I think you may have installed manually. I'd recommend wiping your machine and doing a complete clean reinstall of Ubuntu 12.04 or 14.04 and running the following at a terminal: 1) sudo wget https://raw.githubusercontent.com/lukebranch/odoo-install-scripts/master/odoo-saas4/ubuntu-14-04/odoo_install.sh 2) sudo sh odoo_install.sh let the script run through completely and reboot after it has finished. It should then provide you with a working Odoo 8.0 install on your system. If you have any issues please open an issue on the github repository here: https://github.com/lukebranch/odoo-install-scripts/issues with details about the OS version (eg. Ubuntu 14.04), and any traceback errors (in full) and/or logs.

Luke Branch
on 10/21/14, 12:27 AM
0
Daniel Blanco
On 3/15/15, 10:07 AM

Google code is going to be closed soon.

Here is a replacement for gdata python client

https://github.com/pirxpilot/gdata-python-client

(by the way, does it happen to you, that when you are posting in this form and give an enter, takes you to the bottom of the page?)

0
Malte Helmhold
On 1/1/15, 10:59 AM

I have a lot of Odoo experience now and I do not any other workflow anymore (note: you should alter the master pw after or before using the script) see this youtube video:

https://www.youtube.com/watch?v=FTrDT7Ovjs0

And I guess that everyone can confirm that DO is great:) 

have a great new year 2015!

 

0
oli
On 7/8/14, 4:40 AM

Do you know where i can find windows article for the same  ? 

Hi Oli, Unfortunately I do not have experience in getting this running on Windows. I suggest if you would like to test the platform on your local machine that you download virtualbox and simply setup an Ubuntu 14.04 clean install inside the virtual machine. I suggest you then run my slightly modified version of Andre Schenkel's original script (designed for 64 bit machines) as follows: Modified Script: https://github.com/lukebranch/openerp-install-scripts/blob/master/odoo-saas4/ubuntu-14-04/odoo_install.sh Once you have a clean Ubuntu 14.04 install type this into a terminal: wget https://raw.githubusercontent.com/lukebranch/openerp-install-scripts/master/odoo-saas4/ubuntu-14-04/odoo_install.sh and then type: sudo sh odoo_install.sh the script will then run and install all the required dependencies and setup everything for you. Once it is complete follow the instructions on the screen and reboot the machine. Once you reboot you should be able to access Odoo on your locale (ie. Ubuntu install) by typing into a browser "0.0.0.0:8072" and you should be able to see it on the local network as "http://[insert_your_server_ip_here]:8072".

Luke Branch
on 7/9/14, 10:39 PM

Hi Luke, i tried with VB but ubuntu is very very slow on VB (there are many posts about that on the net). So i test on a VM an test your script. BTW, may you help me to understand github updates. I assume that almost everyday developers update codes and when i follow your script, i get last version. Is that right ? tx for your script + answers.

oli
on 7/16/14, 4:03 PM

i m using azure to create VM, i get below message at last step : pkg_resources.DistributionNotFound: python-ldap Failed to fetch http://azure.archive.ubuntu.com/ubuntu/pool/main/p/python-ldap/python-ldap_2.4.10-1build1_amd64.deb 503 Service Temporarily Unavailable >> i did all update specified, i guess some files are missing from azure, how can i load files elsewhere from azure if needed ? tx

oli
on 7/16/14, 6:16 PM

Hi Oli, In regards to github updates, the script will pull the latest merge onto the 8.0 branch when installing so you will have the latest version at the time of the git clone process in the script. Updating an existing instance of Odoo from github is another matter entirely and it is therefore best to wait to input any considerable amount of data/time until the final version of the 8.0 stable release is announced to the public.

Luke Branch
on 7/16/14, 11:41 PM

in regards to the failed to fetch, I have just tested the download link doing a wget and it works without issue for me. I'm guessing there was a temporary interruption of your connection with the azure.ubuntu.com server that caused the issue. try a wget http://azure.archive.ubuntu.com/ubuntu/pool/main/p/python-ldap/python-ldap_2.4.10-1build1_amd64.deb and the dpkg the .deb you've downloaded, I think it will solve your issue. If you have any trouble post back here.

Luke Branch
on 7/16/14, 11:47 PM

Hi Luke, i did try "wget http://azure.archive.ubuntu.com/ubuntu/pool/main/p/python-ldap/python-ldap_2.4.10-1build1_amd64.deb", i ve got an error : 2014-07-17 05:08:05 ERROR 503: Service Temporarily Unavailable. I guess issue is from azure. tx

oli
on 7/17/14, 1:14 AM

I think this must be due to a restriction from your ISP or similar, or perhaps a restriction on your IP/IP Block from the azure server. I am located in Hong Kong and the link works fine. I've uploaded a temp copy of the file that i've downloaded in Hong Kong here: http://tempsend.com/01DB48E2B1/C619/pythonldap_2.4.101build1_amd64.deb try and wget it. If it works it'll confirm that it's the azure website that is somehow blocking you from a normal download.

Luke Branch
on 7/17/14, 1:23 AM

oh... i can get your temp file..btw i just saw many post about this issue with azure, according to your IP, load balancing root you to specific archives from my understanding. For some regions there are no issues whereas for West Europe region (France) at least, there are. A workaround is to change the repository in /etc/apt/sources.list from azure.archive.ubuntu.com to whatever else official ubuntu mirror, like de.archive.ubuntu.com. I'll try that.tx

oli
on 7/17/14, 1:38 AM

I got all missing files (about 10) from http://security.ubuntu.com/ubuntu/pool/main/p/python-ldap/. now at step #22 "sudo python setup.py install", i get following error : pkg_resources.VersionConflict: (Pillow 2.3.0 (/usr/lib/python2.7/dist-packages), Requirement.parse('pillow==2.0.0,>=2.4.0')), any idea how i can solve that ? tx

oli
on 7/17/14, 2:14 AM

hi, pillow removed then installed. next issue : addon missing : pypdf, fixed see https://github.com/lukebranch/openerp-install-scripts/blob/master/odoo-saas4/ubuntu-14-04/odoo_install.sh. Now application is loading BUT : 1)some modules(application) like internet website are notified on UI as installed whereas there are not accessible/working. 2) some modules are missing from modules list on UI. Do you know how to fixe both issue ? tx

oli
on 7/18/14, 4:51 AM

@oli please provide more details in regards to what is not installed/not working and if you are getting any error messages. Are the not installed modules highlighted in blue (trying to install), red (not installed), or black (installed)? You may also want to switch your logs on to debug mode and check /var/log/odoo/odoo-server.log: sudo pico -w /var/log/odoo/odoo-server.log go down to the bottom and you'll be able to see errors logged if you have used the settings i've provided for /etc/openerp-server.conf (if you set this up manually) or /etc/odoo-server.conf (if you used the script).

Luke Branch
on 7/19/14, 12:38 AM

Hi Luke, I finally moved to below link : https://github.com/lukebranch/openerp-install-scripts/blob/master/odoo-saas4/ubuntu-14-04/odoo_install.sh#L286 and the application is working now with all needed modules. Your post is great but i may have done some mistakes, as installing from wrong path so i didn t get log file installed. May you help on that : As i understand, odoo is under AGPL, so the code is free. According to pricing list, Openerp charges from 2+ users, regarless if solution is hosted by them or not, when you use what they call "access to the Apps Platform". So the question is "what is Apps Plateform" ? I guess it's UI that provides icons which allow you to setup all modules by one clic...may you/someone confirm ? I have setup v8 on my own server from github.com and i got such an UI. So i wonder how can i setup V8 and modules without using that UI. Does someone has a link/process to provide ? Tx

oli
on 7/21/14, 4:34 AM
0
Wouter Tebbens
On 7/21/14, 6:34 AM

I have used André Schenkels installation script (for odoo v8 on Ubuntu 14.04) a few days ago, and it worked neatlessly. I only had to set up the ssh keys, and reverse proxy and the script did all the rest, very smooth :-) 

0

It is very easy to test odoo without installing in to local server / laptop. create a 15 days free trial or create an instance with 2 users and get register for free for lifetime at https://accounts.odoo.com/odoo-enterprise/select-app If you want to test it quickly with demo data you can use http://runbot.odoo.com/runbot you have choice to select the version you want to test it.

0

gunnar

--gunnar--
1153
| 6 7 8
Germany
--gunnar--

born

gunnar
On 5/29/14, 4:12 AM

there is an installation script around where you can chose which version (7.0, master (what is what you call 8 here) or several SaaS version) on github.

https://github.com/aschenkels-ictstudio/openerp-install-scripts/blob/master/odoo-saas4/ubuntu-14-04/odoo_install.shI haven't tested it myself yet but following the discussion on the blog of Andre Schenkels (who made the script) here  it seems it has been debugged and several people have used it successfully. You can't install Oddo more easy than that probably.

Hi Gunnar, I have tested the above mentioned script and it does work very well for the master branch, however it does not seem to install the required dependencies for openerp-gevent mode. I'll post back here once i've figured out necessary modifications to the script to allow it to use both openerp-server and openerp-gevvent mode.

Luke Branch
on 7/2/14, 3:35 AM
0
Ville Jyrkkä
On 5/30/14, 7:57 AM

Above mentioned script is good base for building dev server installation, thanks for sharing!

hi Ville, best practice (within the logic of this forum) for your comment would have been a Comment to the answer you are commenting to instead of an answer. Best way to appreciate an answer would be to click a thumbs rather then expressing it in written. Like that this thread would be ranking higher somewhat and therefore might be accessed by more people.

gunnar
on 5/30/14, 7:38 PM

I would but not yet enough karma to vote.

Ville Jyrkkä
on 6/2/14, 5:54 AM
0
flg
On 7/15/14, 2:50 AM

You may test this script:http://www.schenkels.nl/2014/07/odoo-v8-install-script-github-ubuntu-14-04-lts/

 

0
Robert Koller
On 7/1/14, 9:12 AM

error on 22)

open file 'setup.py': [Errno 2] No such file or directory

Hi Robert, I believe you may be trying this step while in the wrong directory. If you have cloned the git repository at https://www.github.com/odoo/odoo into /opt/odoo/ then setup.py should be accessible from that directory. Please post back with information on which directory you are trying to execute setup.py from.

Luke Branch
on 7/1/14, 9:38 AM
0
Ivan Yelizariev
On 9/16/14, 8:25 AM

I've prepared an intallation instruction on github gist:

https://gist.github.com/yelizariev/2abdd91d00dddc4e4fa4

It tested on ubuntu 14.04.

It works with longpolling (instant messaging - IM)

It uses nginx for port proxing

It has some commands for debuging

One can fork this gist and make necessary modifications

To make installation copy-paste commands in install-odoo.sh file. I recommend copy paste commands line-by-line and check result on each step.

@Ivan Yelizariev, Thanks for your scripts. I'm interested in forking them for inclusion in my own script. Please let me know how I should attribute credit to you.

Luke Branch
on 9/26/14, 7:00 AM

Never mind. Gist makes label " forked from yelizariev/install-odoo.sh" -- it's enough

Ivan Yelizariev
on 9/27/14, 1:24 AM
0
Martin Temmink
On 9/15/14, 9:02 AM

just check my blog:

There are some more requirements for ubuntu 14.04 lts.

And you can easily copy 'n paste the commands for on your commandline.

the blog is hosted: http://temmink.wordpress.com

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

18 follower(s)

Stats

Asked: 5/21/14, 1:54 AM
Seen: 125736 times
Last updated: 5/13/16, 7:30 AM