Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

5

How to install Aeroo Reports?

By
Ahmet Altinisik
on 2/21/13, 5:03 PM 34,256 views

How to install Aeroo Reports on OpenERP V7.0 ?

Aeroo Reports is a reporting engine for OpenERP. With the help of a openoffice instance runnig at server side you can have reports in many formats like. PDF XLS DOC ODT ODS TXT CSV.

Can anyone tell the step by step procedure to start with aeroo reports with openoffice on Windows?

evon_dun
on 6/13/13, 8:23 AM

I have installed this as per the instructions but now i cannot access Openerp - mozilla says "problem loading the page" - this is since i rebooted the server. Help! :)

Oliver Stanton
on 7/1/13, 10:57 AM

Hi Ahmet, Have you had any luck installing Aeroo reports with the 8.0 branch? I'm very interested in being able to export reports to XLS, DOC, ODS, etc, but cannot get it to work with the instructions for v7.0 and the new modules being ported to 8.0 (https://github.com/jamotion/aeroo).

Luke Branch
on 7/16/14, 10:56 PM

Hey Ahmet Altinisik! How do you do to have red characters in your text below?

Pascal Tremblay
on 12/2/14, 2:22 PM
14

Ahmet Altinisik

--Ahmet Altinisik--
2137
| 8 7 10
ANKARA, Turkey
--Ahmet Altinisik--

http://www.altinkaya.eu

Ahmet Altinisik
On 2/21/13, 5:33 PM

I installed Aeroo Reports after installing OpenERP on my Ubuntu 12.04 x64 Server.

If you are a newbie and want to copy paste all of the commands you should install your OpenERP server according to my installation answer.

You can find installation answer to of OpenERP on this page : How to install OpenERP V7.0 on Ubuntu 12.04 from launchpad repository?

Or you need to change the path names

Install required packages and openoffice. (Around 500 mb installation)

sudo apt-get install openoffice.org python-genshi python-cairo python-openoffice python-lxml python-uno
sudo apt-get install zip bzr python-setuptools

Download aeroo library from launchpad and install as a python module

cd ~
bzr branch lp:aeroolib
cd aeroolib/aeroolib/
sudo python ./setup.py install

Create a new folder and download aeroo modules from launchpad to this folder with bzr.

sudo su openerp
cd /opt/openerp/v7/
bzr branch lp:aeroo
exit

Add aeroo directory to the module search path of openerp by editing the config file

sudo nano /etc/openerp-server.conf

change the addons_path as

addons_path = /opt/openerp/v7/addons,/opt/openerp/v7/web/addons,/opt/openerp/v7/aeroo

create an init script for openoffice

sudo nano /etc/init.d/office

Paste this to your script

#!/bin/sh
/usr/bin/soffice --nologo --nofirststartwizard --headless --norestore --invisible "--accept=socket,host=localhost,port=8100,tcpNoDelay=1;urp;" &

Make the file executable and add init script to the startup

sudo chmod +x /etc/init.d/office
sudo update-rc.d office defaults

Run OpenOffice

sudo /etc/init.d/office

You can test your openoffice installation by connecting to openoffice from port 8100

telnet localhost 8100

If you see an output like below it means openoffice is working ok.

Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
e--'com.sun.star.bridge.XProtocolPropertiesUrpProtocolProperties.UrpProtocolPropertiesTidE--L

Restart openerp server to be able to check the additional module directory

sudo /etc/init.d/openerp-server restart

Now you can install aeroo modules from openerp interface.

I also recorded installation from openerp interface you can watch it in Youtube. (since interface is different you may not find where to install at first) http://youtu.be/S1bKPUL6nUU

You can find detailed information about aeroo reports from alistek's web page http://www.alistek.com/

AEROO REPORTS WIKI

To install report_aeroo_ooo on windows, check this answer for OpenOffice and PyUno setup.

Can I install LibreOffice instead OpenOffice? Is it posible?

Miguel Fernández
on 2/22/13, 5:31 AM

OpenOffice replaced with LibreOffice in ubuntu. when you try to install openoffice so it is in fact installing Libre Office in 12.04 version

Altınkaya Elektronik Cihaz Kutuları imalat Ticaret ltd sti, Ahmet Altinisik
on 2/22/13, 8:23 AM

Maybe my question must be: All the lines about OpenOffice works fine with LibreOffice or must be change something?

Miguel Fernández
on 2/22/13, 11:10 AM

Nothing to change just write the commands as it is it will install Libre. It is %100 compatible

Altınkaya Elektronik Cihaz Kutuları imalat Ticaret ltd sti, Ahmet Altinisik
on 2/23/13, 4:10 AM

Thank you. I'll try it.

Miguel Fernández
on 2/25/13, 8:34 AM

If you hit the following error after installing Aeroo reports (at least Ubuntu 12.04)

Traceback (most recent call last):

File "/opt/openerp/software/70/aeroo/report_aeroo/report_aeroo.py", line 439, in create_aeroo_report

data = basic.generate(**oo_parser.localcontext).render().getvalue()

check the Genshi version. It should be 0.6. Version 0.7 did not work for me.

LUOSTO COMMUNICATIONS, Markku Luosto
on 3/27/13, 10:31 AM

Thanks for the great tutorial! Lots of good info!

Kevin Shenk
on 4/9/13, 12:36 PM

One question, I'm new to bzr, so I can't say for sure, but isn't 'bzr checkout --lightweight' better for this purpose than 'bzr branch'? My understanding is that a lightweight checkout will download less information and take less time but can still be updated...

Kevin Shenk
on 4/9/13, 12:38 PM

As noted, the http://openoffice.org package is a metapackage that installs libreoffice. Running 'apt-get install openoffice.org' installs a TON of packages. I've replaced that with 'apt-get install libreoffice-writer libreoffice-calc'. This gives a much lighter install and Aeroo is working great.

Kevin Shenk
on 4/10/13, 12:04 PM

I followed these instructions and when I restarted the server, it gave me this error "No handler found.". What's the problem? Thanks!

Zakaria
on 6/12/13, 8:24 AM

I keep getting: root@cloudgrippa:~# telnet localhost 8100 Trying 127.0.0.1... telnet: Unable to connect to remote host: Connection refused

Oliver Stanton
on 7/1/13, 9:22 AM

Excellent!

Group ODOO
on 10/5/13, 12:03 PM

I run sudo /etc/init.d/office nothing happen and run telnet localhost 8100 connection refused. I don't know what went wrong. Any idea? Thanks

Johny Doe
on 1/9/14, 12:37 AM

Thanks Ahmet

This saved the day for me. I have voted for this answer

Dale
on 4/3/14, 8:04 PM

If anyone is looking for how to install this in Odoo 8.0 please refer to the following forum post (*includes an installation script): https://www.odoo.com/forum/help-1/question/8-0-how-can-i-install-the-official-aeroo-reports-alistek-for-odoo-version-8-solved-76044

Luke Branch
on 5/25/15, 4:52 AM
2
Julius
On 7/4/13, 1:33 PM

For those encountering "Connection refused" when trying to telnet to their soffice headless, you can try this alternative command (it worked for me):

/usr/bin/soffice -headless -accept="socket,host=localhost,port=8100;urp;" -nofirststartwizard &
0
ksp serge
On 7/16/14, 1:35 PM

Hello,

I'am struggling to install report_aeroo_ooo on OpenERP 7.0 on Ubunut 12.04, here is the message of error I've got :
Warning! Unmet python dependencies!

No module named uno
No module named unohelper
No module named com.sun.star.beans
No module named com.sun.star.uno
No module named com.sun.star.connection
No module named com.sun.star.beans
No module named com.sun.star.lang
No module named com.sun.star.io
No module named com.sun.star.io

My Ubuntu 12.04 server is on bitnami amazon cloud server, I've installed it using OpenERP stack provided by bitnami.

Thank you for help!

use command sudo apt-get install uno. this is the error of dependencies.

NetbeamERP Technology
on 7/16/14, 3:04 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

4 follower(s)

Stats

Asked: 2/21/13, 5:03 PM
Seen: 34256 times
Last updated: 3/16/15, 8:10 AM