Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

2

How to get multicurrency working in v8

By
Kurt Haselwimmer
on 9/27/14, 2:00 AM 1,558 views

There appears to be a difference between v8RC1 (saas5) and v8 (saas6) in multicurrency setup as it seems impossible to set exchange gain and loss accounts under settings/configuration/accounting. After clicking on apply the set account numbers disappear and it seems that they have not been set.

All the usual user settings (multicurrency, sale pricelist, purchase pricelist) have been set, and the euro currency (rate=1.000) has been set to base.

I have the same problem. As I look in the account_config_settings in Postgres, there are no fields defined for income_currency_exchange_account_id and expense_currency_exchange_account_id. I may later add these fields in Postgres to see if it works as a temporary workaround.

Rooms For (Hong Kong) Limited, Yoshi Tashiro
on 9/27/14, 4:07 AM

Is it really possible that such a critical feature like this can suddenly 'break' between v8RC1 and v8 'stable' ?

Hertford Developments Limited, Kurt Haselwimmer
on 9/27/14, 4:27 AM

When V7 came out there were many issues kind of like this, so I'm not so surprised. Not sure how it could happen between V8RC and V8, though.

Rooms For (Hong Kong) Limited, Yoshi Tashiro
on 9/27/14, 4:38 AM

v8 has been trailed for 9 months, issues like these, if they are real issues and not just the results of some other misconfiguration (please someone tell me that it is) should have been fixed at v8RC1 at the latest.

Hertford Developments Limited, Kurt Haselwimmer
on 9/27/14, 5:28 AM
1
Kurt Haselwimmer
On 10/9/14, 3:22 PM

Odoo confirmed this as a bug after I posted on github as issue no 2851 (https://github.com/odoo/odoo/issues/2851) - this was fixed with 'pull request' 2880 (https://github.com/odoo/odoo/pull/2880). As of  9 Oct 2014 this fix appears to have been merged with the v8 running on odoo SA's saas (not sure what other branches it has been merged with, or how to find out) as the error does not occur any more.

Moral - do not hold back from reporting issues on github - there's more chance that a programmer will see it there than on this forum.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

3 follower(s)

Stats

Asked: 9/27/14, 2:00 AM
Seen: 1558 times
Last updated: 3/16/15, 8:10 AM