Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

How to find custom modules?

By
Martin
on 6/21/13, 4:58 PM 4,058 views

I'm using the Debian package version 7.0-20130620-231038-1. I'm trying to get a custom module (for testing I used the notebook example from iBCScorp) running, but failed. I first tried to just put the directory in /usr/share/pyshared/openerp/addons/ (the permission are OK, everything world-readable), restarted the server with --update=all, but it didn't work. I also tried with putting the module into (again world-readable) path and the additional parameter --addons-path=/usr/local/src/openerp/testbed/addons/, but again, I can't see the module in the web interface. Is there anything obvious, I forgot? TIA!

0
Martin
On 6/23/13, 6:47 PM

OK, it does now work for me! Even, if I'm not sure, whether the solution is correct or not:

I need to put the modules under

/usr/share/pyshared/openerp/addons/mymodule/

plus - and this is the point I missed before:

symlinks for every single file in above directory under the directory

/usr/lib/pymodules/python2.7/openerp/addons/mymodule/

e.g. /usr/lib/pymodules/python2.7/openerp/addons/mymodule/__init__.py points to /usr/share/pyshared/openerp/addons/mymodule/__init__.py etc.

Thanks to everybody for your help!

Does anyone know, if there is a smart little Linux shell script to do this task? Creating all the symlinks can be quite time-consuming... In our installation we have also a second directory "/usr/lib/pymodules/python2.6/openerp/addons/" where the links should be created.

memoComp oHG, Klaus Hagemann
on 8/28/14, 4:03 AM
0
Paul Ridley
On 6/23/13, 10:15 AM

Hi Martin,

sometimes when you are installing OpenERP you can be accident create multiple locations where the openerp directories (server,web.,addons,..) are stored. It sounds like you may be placing your custom module in an addons directory that is different from the one used from the start up script.

I suggest that you first look at the startup script and find which openerp.config file it is pointing to. In this openerp.config file you will find the location of the addons folder being accessed by the openerp server. Finally place your custom module in this addons folder, restart the openerp server and hopefully you will now see your module.

An addtional thing that sometimes confuses people is when searching for your module in the web interface (Settings->Modules->Installed Modules) the default filter only shows modules which have already been installed. Make sure that yuo delete this filter so that you can see all installed and not installed modules.

Maybe one of both of these things can help you.

kind regards

Paul Pawri Group BV www.pawri.nl

I checked this, but there were no additional directories. As I wrote, I'm using the Debian package directly from the nightly builds directory, not a custom install. I'm also aware of the filtered view.

Martin
on 6/23/13, 6:42 PM
0
Dharmesh Rathod
On 6/22/13, 2:36 PM

Hi,

Please check file __openerp__.py There is one attribute you have to check :

'installable': True

It may be "False" so check it.

Thanks
Acespritech Solutions Pvt Ltd
http://www.acespritech.com
http://acespritechblog.wordpress.com

It is set to True already. The complete notebook example __openerp__.py is: { "name" : "notebook", "version" : "0.1", "author" : "Keerthi Bandara @ iBCScorp", "website" : "http://www.ibcscorp.com/", "category" : "Generic Modules/Others", "depends" : ["base"], "description" : "Simple demo module", "init_xml" : ["notebook_view.xml"], "demo_xml" : [], "update_xml" : [], "active": False, "installable": True }

Martin
on 6/22/13, 5:20 PM
0
mmycool
On 6/21/13, 7:00 PM

I usually place my custom modules in /usr/lib/pymodules/python2.7/openerp/addons/ ...then do Settings --> Modules --> Update Module List ...and they work. Try it!

Unfortunately, this did not work for me. I wonder, whether maybe my example modules are broken in some way...

Martin
on 6/22/13, 7:32 PM
0

Ray Carnes

--Ray Carnes--
15677
| 9 7 9
Greater Los Angeles, United States
--Ray Carnes--

Senior Odoo Analyst

OpenERP 6.1, 7.0 and Odoo 8.0, 9.0 (Since 2012)

Completed Functional and Technical Training.

Major Skills:

  • Needs Discovery and Requirements Analysis;

  • Function and Technical Specifications;

  • Project Planning;

  • Prototyping and Proof of concepts;

  • Data migration;

  • Configuration & Customization (UI and modules);

  • Integration - data, business logic and service levels;

  • Training and Knowledge transfer;

  • Go Live support;

  • Help desk;

  • Version Migration.

I have over 20 years of experience empowering and enabling users with enterprise information systems that make a real and measurable difference in their ability to proactively manage their businesses and organizations. 

Ray Carnes
On 6/21/13, 5:16 PM

When an OpenERP database is created, the systems looks in the addons path and 'loads' metadata about the modules it finds.

--update=all will look at this metadata and re-load all of the module sources, but won't do anything with 'new' modules.

If you put a module into the addons path, you need to trigger OpenERP to update the module metadata.

Settings --> Modules --> Update Module List

Then, any modules that have been added to the system since the creation of the database, or since the last time the module list was updated, will appear (providing they are valid and can be seen by the OpenERP process).

Unfortunately, this does not have any visible effect. Is there any way to debug this? Of course, I already looked for errors and the module names in the log files, but nothing... I'm sure, I'm missing something very stupid, but what?

Martin
on 6/22/13, 10:27 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 6/21/13, 4:58 PM
Seen: 4058 times
Last updated: 3/16/15, 8:10 AM