Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

4

How to disable Google Analytics?

By
Martin
on 3/8/13, 9:09 AM 3,271 views

Version 7 is poisoned with Google Analytics. What is the reason for this and how can I prevent this? If I can not eliminate Google Analytics (or any other ghostware...) I will never ever be able to bring OpenERP into production mode with our company.

3

Fabien Pinckaers (fp)

--Fabien Pinckaers (fp)--
6598
| 6 8 8
fsdsdfsdf, Belgium
--Fabien Pinckaers (fp)--

Odoo Founder & CEO

Fabien Pinckaers (fp)
On 3/8/13, 9:28 AM

If you have google analytics, it's because you installed the web_analytics module which is not installed by default.

OpenERP uses google analytics to get statistics on what to improve for future versions of OpenERP. It allows the R&D teams to measure usage of the different objects to detect the ones that should be improved.

It would be fair for customers to be informed on this by the product, so that they could have a choice to opt out.

Daniel Reis
on 3/8/13, 5:27 PM

What is not fair about this? It is not installed by default and there is a description explaining exactly what it does.

Fabrice Henrion (fhe)
on 3/8/13, 6:07 PM

I think you're talking about two different things...

I see this behavior. Once I go to Settings->Apps the google-analytics JS gets included in every page header.

But we never had the Google Analytics module installed!

Thomas
on 7/9/13, 10:42 AM
2
Nicholas Linn
On 3/8/13, 9:25 AM

Don't install or, if it's installed, uninstall the web_analytics module. It's not required.

1
Vincent Van Dyck
On 6/4/13, 5:45 AM

May be a bug ?

Using Noscript addon + Ghostery addon under firefox 20.0 , OpenERP Version 7.0-20130602-231021

Log on : undetected

Go to Settings ("| Modules | Apps" selected by default) : detected by both Noscript and Ghostery

Go to Settings | Modules | Installed Modules + reload page : undetected

Check that Google analytics (web_analytics) is NOT installed : OK

Go back to Settings | Modules | Apps : again, detected by Noscript and Ghostery

Reproductible with different dbs.

Cheers

I see exactly the same behavior. Once I go to Settings->Apps the google-analytics JS gets included in every page header.

Must be a bug surely as we never had the Google Analytics module installed!

Thomas
on 6/18/13, 9:57 AM

Hi, some advance about this behavior? Thx.

Juanjo Algaz
on 6/24/13, 9:36 AM

Strange bug... and probably not on the road map. G. Orwell, are you watching me ?

Vincent Van Dyck
on 9/23/14, 9:29 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

3 follower(s)

Stats

Asked: 3/8/13, 9:09 AM
Seen: 3271 times
Last updated: 4/12/16, 11:47 AM