Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

9

How to define the thousands separator?

By
Josse Colpaert (jco)
on 2/1/13, 8:02 AM 25,037 views

Accountants are used to the thousands separator e.g. 102563.00 EUR is represented as 102,563.00 for the sake of clarity. How to enable it?

This question has been included in the official documentation.
19

Guewen Baconnier - Software Developer, Camptocamp

--Guewen Baconnier - Software Developer, Camptocamp--
2658
| 6 7 8
Lausanne, Switzerland
--Guewen Baconnier - Software Developer, Camptocamp--

Guewen works at Camptocamp as an Odoo developer since 2010. He is the lead developer of the Odoo Connector framework and the Magento Connector. He is a delegate member of the OCA, a committer and an active contributor to the OCA projects.

 

Guewen Baconnier - Software Developer, Camptocamp
On 2/5/13, 9:25 AM

The setup of the thousands separator is located under: Settings > Translations > Languages.

For each language, you can set a different separator format (and few other formatting options like the dates format or the text direction).

3 options modify the format of a number:

  • Separator format: number of digits between separators
  • Thousands Separator: the character displayed at each separation
  • Decimal Separator: character displayed before the decimals

If you use [3,3,3,-1], the number 1232345.01 will be displayed 1,232,345.01. However, the number 1237891232345.01 will be displayed 1237'891'232'345.01.

The -1 at the end of the list means 'stop the separation'. The value 0 can be used to mean 'repeat the last group at infinite'.

So the correct form for a separator between each 3 digits whatever the number of digits is: [3, 0].

Reference: Olivier Dony's comment

But it dont work with e-mail template! REFERENCES Order number: SO008 Order total: 7315.0 EUR

Metrolux Gmbh, Andreas Marpmann
on 5/26/14, 1:48 PM

i have made these changes but got js error , undefine seprator bcz i think by mistake i have do this way [,3,3,3, -1] now please tell me how to resolve it please help me

Atul Kumar jain
on 6/9/14, 11:30 AM
This question has been included in the official documentation.
2
Andreas Marpmann
On 8/15/14, 5:40 AM

Sorry for the repetition as answer. The separator is not working in email templates!

Me too some one has it solved?

Carlos Contreras
on 4/20/15, 2:40 PM
This question has been included in the official documentation.
2

Under Settings > Languages > Your favorite language you will find two fields: thousands separator which is , in English by default, but to make it work you also need to set the Separator Format. [3,3,3,-1] will make sure e.g. that 1232345.01 EUR appears as 1,232,345.01 EUR. The tooltip of the Separator Format will show you that the separator is fully customizable. Apparently, some countries prefer 4 instead of 3 digits for separation.

Please see my response, the format [3,3,3,-1] is not correct when the number of digits is > 12.

Camptocamp SA, Guewen Baconnier - Software Developer, Camptocamp
on 2/5/13, 9:26 AM

I found that by doing exactly this, a number such as 108,253 is changed automatically into 108 when creating accounting entries. I used [3,3,3,-1], "," as decimal and "." as thousands separator.

Scalaria S.A.S., Bernardo Romero
on 2/7/13, 7:03 PM

That is because I used the . as decimal and , as thousands separator and you do the opposite. The precision of your accounting entries depends on the Decimal Precision in the Technical Features.

Josse Colpaert (jco)
on 2/13/13, 9:02 AM

i have made these changes but got js error , undefine seprator

Atul Kumar jain
on 6/9/14, 11:16 AM

i have used by mistake [,3,3,3, -1] now please tell me how to resolve it

Atul Kumar jain
on 6/9/14, 11:18 AM
This question has been included in the official documentation.
0
Ivan Wellistya
On 10/15/15, 5:06 AM


Moved to "ask a question".. sorry

This question has been included in the official documentation.
0
ChangJoon Lee
On 3/2/15, 7:19 AM

To see [Language] menu under [Translation], your user account should be enabled for [Technical Features] even if you are System Administrator.

 

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

3 follower(s)

Stats

Asked: 2/1/13, 8:02 AM
Seen: 25037 times
Last updated: 4/26/16, 1:45 AM