Help

0

How to configure multi-instance and memory limit in .conf ?

Avatar
Olivier B.

We have 3 instances in a single server with different ports (8069, 8040, 8060) and different Odoo version (10, 11, 12). Server specifications are 4 CPU and 8Go RAM.

We have an issue with Odoo 12 only, he crash sometimes. In the log, we have these lines : "virtual real time limit (181/120s) reached."

We tried many manipulations found on the web, like change memory limit, change number of workers... Nothing change. Moreover, when we activate workers, we have another issue : "raise Exception("Exception: bus.Bus unavailable")"

We delete configuration line about longpolling port too, nothing change.

Our Odoo configuration :



Our Nginx configuration :



How to configure the serveur for multi-instance ? When Odoo documentation give us a calculation method for memory, does it work for multi-instance too ?

Thank you

Avatar
Discard
1 Answer
0
Avatar
Khaled Hamed
Best Answer

By default limit-time-real is responsible for this issue as the default value is 120

You can set  the following parameter  on Odoo configuration file to number larger than 120 if the file your import file has large number of records.

e.g:

limit-time-real=600


Be aware that the default value protects odoo.service.server instance from being on hold for a long time thus consume server's resources.


Avatar
Discard