Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

2

How to change products' cost decimal precision?

By
Olivier Lallemand
on 2/13/13, 10:36 AM 18,553 views

I have a problem with decimal precision. I've seen a lot of posts about it on the net but I think it's for earlier version. I just want to specify 5 decimals in the product cost price.

First, thanks for your help. But i didn't find the system configuration.

Olivier Lallemand
on 2/13/13, 10:56 AM

Is there a tools to instal or is it build in the web client ?

Olivier Lallemand
on 2/13/13, 11:39 AM

Hi,

I have the same problem, so the answer really interests me :)

Regards,

Olivier Mawet
on 2/13/13, 11:44 AM

Settings option in system.

Cristian Salamea
on 5/21/13, 5:27 PM
9
Mihalache Ciprian
On 2/13/13, 12:24 PM

image description

I attached an image:

First go to

Settings -> Users -> Select user and under access rights tab check technical features

Reload page (F5)

Go To

Settings -> Database Structure -> Decimal Accuracy

You must restart the server for changes to take effect. In Windows, go to Control Panel, Administrative Tools, Services. Find OpenERP in the list. Stop then Start the service.

Hi, we have found a problem in this regard. The thing is that changing the number of digits in the "Product Price" not only changes the digits in "Sale Price" but also in "Cost Price". Is there any way to handle these two concepts (Sales Price / Cost Price) separately?

Javier Fuentes
on 2/26/13, 6:43 AM

Not from configuration but using customization you can do that.

Mustufa Rangwala (mra)
on 3/22/13, 7:25 AM
0
Igor Sjeverac
On 5/19/15, 6:55 AM

Hello everyone,

This is old question but this configuration works for me:
http://netjunky.net/change-odoo-decimal-precision-configuration/

Kind regards,

Igor


0
William Zhang
On 7/21/14, 1:53 PM

I just updated all these, form shows without decimal point. But when i take a print out of the same form it shows decimal point. Any solution for this,Mustufa Rangwala?

0
rashed
On 4/28/14, 5:09 PM

hi how can i change in pos since it show me 3 decimal but the third number is 0 always?

example in the products 2.253 in the point of sale it shows me 2.250

thanks in advance.

i try all above and change the value Product Decimal 4 still in point of sale show me 2.250 instead of 2.253

rashed
on 5/11/14, 3:46 PM

thanks to mr Ahmad the answer worked in my pos

rashed
on 5/12/14, 3:38 PM
change your Account precision to 4 "you already did that"
change your default company currency Rounding Factor to 0.0001, You can find it under Settings ->Configuration ->Accounting ->Options, Default company currency.
on the file /addons/point_of_sale/static/src/js, open the widget_base.js and make these changes:
    line 25 

this.currency = {symbol: '$', position: 'after', rounding: 0.0001}; // change the 0.01 to 0.0001
    line 32 

amount = Math.round(amount*10000)/10000; // change 100 to 10000
rashed
on 5/12/14, 3:39 PM
0
Jānis
On 2/13/13, 12:10 PM

Go to menu Settings / Technical / Database Structure / Decimal Accuracy , open Product Price and change the field Digits to your needs.

If you can't see this menu then install module decimal_precision.

0
Cristian Salamea
On 2/13/13, 10:49 AM

Hello in system configuration, Database estructure menu you will get each decimal precision option. Product Decimal precision is what you need to set.

Regards,

i set all to 4 same thing 2.250

rashed
on 5/11/14, 3:17 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 2/13/13, 10:36 AM
Seen: 18553 times
Last updated: 5/19/15, 6:55 AM