Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

How to avoid "too many open files problem"?

By
David Arnold
on 10/14/14, 1:46 AM 687 views

I'm on a VPS which has an open file limit. Odoo is quite havy in his open files... 

BTW, can anyone answer why this is so?

 

Is there a solution to lower odoos footrint?

I found a command 'lsof' on the web and it shows that postgresql is a heavy 'sinner' - anyone got an idea what to do?

David Arnold
on 10/14/14, 10:43 AM
0

Ahmed M.Elmubarak

--Ahmed M.Elmubarak--
2988
| 5 3 5
Sudan
--Ahmed M.Elmubarak--


Ahmed M.Elmubarak
On 12/3/16, 5:07 AM

Hi, David,

As lsof; most probably the cause is the postgres ... you can try to fix postgres by setting the max_files_per_process in postgresql.conf the default is 1000 so you can reduce this number ...

Hope this could helps a little bit ...

0
Bisi
On 12/2/16, 5:26 PM

What's the solution/workaround to this issue?

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 10/14/14, 1:46 AM
Seen: 687 times
Last updated: 12/3/16, 5:07 AM