Odoo Help

0

How to auto set sales team field in sales/quotations?

By
Hammad hussain qureshi
on 2/13/15, 1:42 AM 1,048 views

I have defined a sales team with some members that I have properly configured. Everything is working fine but the issue is that when I logged using a member of that newly created team, on creating a new quotation/sale, the sales team field in other information is not set automatically, while the sales person field is set automatically as expected. Is this is openERP's default behaviour or there's some bug in my system?

Can there's any way to set this sales team field automatically? The company's sales person can only be in one sales team at a time, so there will be no conflit in selecting appropriate team. Thanks in advance. 

PS: Already tried to set default sales team but the problem is still there

0
Danijel
On 2/17/15, 8:18 AM

If you want to change the default value to something that is not listed in the Default dropdown, then you should do the following (it's way faster thank anything else and there's no need to change the code):

Fill the field with wanted value (sales person in your case) which you want to set to default and THEN go to the developer mode, Click on Debug View dropdown and select Set Defaults. Now you see you have a NEW (exactly the one you wanted) default value in the dropdown, which you can select. You can make it as default for current (logged) user or for everyone.

This should definetly help you.

0

In User configuration, you could select your default sales team.

Settings --> Users --> select default sales team for that particular user.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 2/13/15, 1:42 AM
Seen: 1048 times
Last updated: 3/16/15, 8:10 AM