Odoo Help


How to activate a created user?

Marcel Rushingwa MPENZI
on 2/23/13, 9:33 AM 5,484 views

I have installed openerp7 home and I've noticed a problem, there is obviously no way to set a user that has been created. In fact, we have completed the user's form, checked the box, put a new password ( the password's field which is hard to find) and then saved.

After that, it happens that the form state does not change and remains "new".

And when you want to connect with the created user, it is impossible.

How to check and make sure my user is usable?

I am not sure if I understand what exactly you want, but newly created user will remain stated as "New" until he make a successful login, this will change the status to "Active".

And yes, there is a problem with the Active check box, that if I unchecked it for New or Active user, this will hide the user and thus it is not possible to login with it again.

You can change the Active status from the database, it is located inside "res_users"

Smart Way Business Solutions, Anas Taji
on 2/23/13, 11:13 AM

I made your question a bit more readable.

Camptocamp SA
on 2/23/13, 10:38 PM

A user will be Active only once he has connected for the first time. So focus on why the user cannot connect.

Camptocamp SA
on 2/25/13, 5:59 AM

Yannick Vaucher - Camptocamp

--Yannick Vaucher - Camptocamp--

| 5 7 9
Lausanne, Switzerland
--Yannick Vaucher - Camptocamp--
Yannick Vaucher - Camptocamp
On 2/23/13, 10:53 PM

A user will change from New state to Active only once he has logged in once.

If your user cannot log in, you might want to search in database if your user has a password and is active.

For that do the following request in your database:

SELECT * FROM res_users WHERE login = '<login>';

If column password is empty this means you didn't properly set the password.

You can go in OpenERP in User's form click on Options -> Set password on top of the form.

You can also change the password in db:

UPDATE res_users SET password = '<new_password>' WHERE login = '<login>';

Otherwise, it might be the active field which is set to False.

If you don't see the created user in users list, you have to add an advanced filter, active = False in the search bar. Then open the user, check the active box and save.

You also can change it in db:

UPDATE res_users SET active = TRUE WHERE login = '<login>';
Jignesh Rathod (jir)
On 5/8/13, 11:03 AM

You can use Option ( Advance search ) for user by active = False , or by query Select active from res_users where login=(Your login ID).

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

0 follower(s)


Asked: 2/23/13, 9:33 AM
Seen: 5484 times
Last updated: 3/16/15, 8:10 AM