Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

How to access Odoo website without logging in (as for public)?

By
Tim
on 6/11/16, 12:09 AM 621 views

I created a website with the Odoo website builder module. Now I want to access this website without having to log in Odoo. How do I do that? For example, my Odoo 9 is at 192.186.0.2:8080 but I face the login at this address. What is the address for the website on my LAN? Website is public so not need for anyone to log in to view my website.

check the port in your odoo-server.config

Prakash Sharma
on 6/11/16, 2:17 AM

I didn't see any line relating to website address in the openerp-server.conf other than 8080 (xmlrpc_port) for Odoo itself

Tim
on 6/11/16, 4:21 PM

Sorry, I mistyped the IP address. it's actually 192.168.1.94, just a normal IP address assigned by the DHCP. Not the router IP address. My mistake.

Tim
on 6/11/16, 4:25 PM
0
Tim
On 6/11/16, 7:02 PM

I found the solution. I got the website working while you have multiple databases loaded by appending "/?db=xxx" where xxx is the name of your database with desired website (created from Odoo Website Builder) to your odoo instance URL.

For example if your Odoo URL is localhost:8080 then to view your website at localhost:8080/?db=xxx where xxx is the name of database. That's it.

This won't be necessary if you only have one database loaded in the system (postgressql).

0

Jérémy Kersten (jke)

--Jérémy Kersten (jke)--
2983
| 3 2 5
Jodoigne, Belgium
--Jérémy Kersten (jke)--

Jérémy is a member of the core R&D team since september 2013. He developed several projects for OpenERP version 8 including the eCommerce, the Google Calendar synchronization and the new product variants/configurator. Now, he manages Odoo website and themes for saas.

Jérémy Kersten (jke)
On 6/11/16, 3:23 PM

Seems like your 'first page' / homepage needs authentication...

When you go on "http(s)://192.186.0.2:8080"... on which url are you redirected ? 

yes there is authentication at 192.168.1.94:8080 to access Odoo backend, but I meant how to access the website that I created with Odoo Website Builder module. I don't want to log in Odoo and then access the website from there. I don't want my peers to log in my Odoo just to view the website. What is the proper address (port?) to view the website normally?

Tim
on 6/11/16, 4:23 PM

The url should be the same. What is the url in the top bar ? <br/>

192.168.1.94:8080/web ?

Jérémy Kersten (jke)
on 6/11/16, 4:25 PM

yes the url is same but i get login which i don't want to log in just to view the website. how can my other peers view the website without having to log in Odoo? it's same idea as you view any other website on the internet without having to log in. i want this same for my LAN for my colleagues to view the website that i created with Odoo Website Builder.

Tim
on 6/11/16, 4:30 PM

'The url is the same ...' WHAT IS the url ?

xxx:8080/??????????????????????????????????????

Jérémy Kersten (jke)
on 6/11/16, 4:32 PM

it's http://192.168.1.94:8080/page/homepage but i get 404 error if i'm not logged in. i can access to the page only when i'm logged in.

both http://192.168.1.94:8080/page/homepage and http://192.168.1.94:8080 point to same home page

Tim
on 6/11/16, 5:01 PM

Ok, so your are not face to the login page :/ But a 404 :)

Do you have custom module ? Do you have some error in your log.

Else, are you sure that you have no group on your view ?

By default, controller page is public... Check that you have a ir.ui.view whey key=homepage, active=True and without group on this view.

Jérémy Kersten (jke)
on 6/11/16, 5:07 PM

nope, i don't have any custom module installed. where can i check my view? "system parameters" under settings menu?

Tim
on 6/11/16, 5:35 PM

i see several ir.ui.view objects in the "views" menu under the user interface. is that what you referred to?

Tim
on 6/11/16, 5:40 PM

yes, it is...

You should find an 'homepage' view. click on it to open, and take a look in the 'key' field.

Check also that you don't have changed access right on it, added groups or inactive it.

Jérémy Kersten (jke)
on 6/11/16, 5:46 PM

i found the view named "Homepage" with the following settings:

view name: Homepage

Website:

Key: website.homepage

View Type: QWeb

Object:

Sequence: 29

Child Field:

Inherited View:

View inheritance mode: Base view

Model Data: Homepage

External ID: website.homepage

Active: checked

i have changed the key field to homepage (was website.homepage) but it doesn't solve the issue.

Tim
on 6/11/16, 6:12 PM

and there is no groups assigned as well

Tim
on 6/11/16, 6:13 PM

I got it working. See the answer above. It's simple actually. Thanks for your help though.

Tim
on 6/11/16, 7:05 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

3 follower(s)

Stats

Asked: 6/11/16, 12:09 AM
Seen: 621 times
Last updated: 6/11/16, 7:05 PM