Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

How do I change the file path that Odoo runs from?

By
Jaron Soininen
on 6/22/14, 11:40 AM 1,682 views

Hi All,

I'm trying to update from Odoo 7 to Odoo 8 trunk on a linux Centos 6.4 server.

I was using Python 2.6 with Odoo 7, but updated to Python 2.7 for Odoo 8.

My problem is that when I run 'service openerp start' I receive the following message:

$ service openerp start
Starting OpenERP Server Daemon (openerp-server):           [  OK  ]
[root@secure ~]
$ Traceback (most recent call last):
  File "/usr/bin/openerp-server", line 4, in <module>
    import pkg_resources
  File "/usr/lib/python2.6/site-packages/setuptools-0.6c11-py2.6.egg/pkg_resources.py", line 2603, in <module>
    """Split a string or iterable thereof into (section,content) pairs
  File "/usr/lib/python2.6/site-packages/setuptools-0.6c11-py2.6.egg/pkg_resources.py", line 666, in require
    for callback in self.callbacks:
  File "/usr/lib/python2.6/site-packages/setuptools-0.6c11-py2.6.egg/pkg_resources.py", line 565, in resolve
    )
pkg_resources.DistributionNotFound: openerp==8.0dev-20140416-230101

I noticed that the traceback above is referencing files at /usr/lib/python2.6/site-packages/ which is where Odoo 7 was originally installed. However Python 2.7 and Odoo 8 was installed at /usr/local/lib/python2.7/site-packages/

How do I make Odoo run out of /usr/local/lib/python2.7/site-packages/ instead of /usr/lib/python2.6/site-packages/ ?

I've updated my openerp-server.conf file to include the following addons path, but it doesn't make any difference.

addons_path = /usr/local/lib/python2.7/site-packages/openerp-8.0dev_20140416_230101-py2.7.egg/openerp/addons

Please help, I've been trying to install and use Odoo 8 for 6hrs now and am going around in circles.

0
Jaron Soininen
On 6/22/14, 1:05 PM

Hi all,

Nevermind I just worked this out.

I needed to change some permissions using chown openerp:openerp on the following files:

tmp/openerp/openerp-server

etc/openerp-server.conf

And then change to the openerp user and start openerp while specifying the openerp-server.conf file.

sudo su openerp

openerp-server -c /etc/openerp-server.conf

Finally a working Odoo 8! Time to have some fun.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 6/22/14, 11:40 AM
Seen: 1682 times
Last updated: 7/27/15, 9:44 PM