Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Field doesn't have translation

on 8/27/13, 3:17 PM 2,228 views

I've search everywhere, and I don't find this field. I'm using the module CRM as example:

#. module: crm
#: model:ir.actions.act_window,name:crm.crm_case_categ_phone_incoming0
#: model:ir.ui.menu,name:crm.menu_crm_case_phone_inbound
msgid "Logged Calls"
msgstr "Appels"

This "Logged Calls" field appears in the left menu side, but what I'm trying to find is the field: "Unit of Measure Categories" that is also in the left menu side. I'm currently in this url: openerp\addons\crm\i18n I already searched in another languages, but I can't find that field. Anyone can help me?


Grover Menacho

--Grover Menacho--
| 5 7 8
La Paz, Bolivia
--Grover Menacho--

Systems Engineer + MBA

Grover Menacho
On 8/27/13, 8:07 PM

Unit of Measure Categories is not a menu added by CRM,

You can find the translations on these modules:

  • product
  • purchase
  • stock

If that doesn't work for some reason, for example in Spanish "Purchases" doesn't change at all. I have to do this:

Settings > User Interface > Menu Items

And there you have to write on searchbox "Unit of Measure Categories" and press "Search Menu for: Unit of Measure Categories"

There you can find your menu. Press Edit and look for this:

image description

As you can see on the right side there is a translation icon. Press that icon and update the Translation Value.

I hope this can help you.

Worked like a charm. Thanks!

on 8/29/13, 6:45 AM

One more question: what is the best approach for translating modules? Because, If I translate them in the online management, and if I install a different instance of OpenERP in another computer, I will not have the translations I've made in the first one.

I should look in the server\openerp\addons\theModuleName\i18n, translate the modules I want, and after that, copy and replace the files in the new instance of OpenERP?

If so, those modules also contain the "Menu Items Fields"? Thanks!

on 8/30/13, 2:52 PM
On 8/28/13, 3:42 PM


First of all thanks. You actually were right. This field "Unit of Measure Categories", was both in the module "Stock" and "Products", I edit the file in both modules, I save them and then I went to the Settings Menu, and I perform the "Upgrade Button" (which says it updates the translations, views, etc) although I did this steps, nothing changed in the CRM view. It continues the field to appear as "Unit of Measure Categories".

My openERP is instaled on a Windows Machine and I tried to restart the service of the openERP in the "Service Manager Menu" of windows, but nothing changes..maybe I'm not performing the restart the correct way.


Answer updated, if it worked please mark the answer as correct.

GH Mediacloud, Grover Menacho
on 8/28/13, 4:39 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)


Asked: 8/27/13, 3:17 PM
Seen: 2228 times
Last updated: 3/16/15, 8:10 AM