Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Etherpad Pad creation failed, either there is a problem with your pad server URL or with your connection.

By
Cody Unrath
on 8/23/16, 5:16 PM 364 views

I am running Odoo 9 on Debian 8 proxied with nginx SSL.

I have Etherpad-Lite running with it's internal SSL on https://servername.com:9001

I am able to access both Odoo and Etherpad from Firefox, Chrome and Opera, but the Project --> Task --> Edit button gives me the error: Pad creation failed, either there is a problem with your pad server URL or with your connection.

Neither the Odoo or ngnix logs have errors, and when I disable the etherpad SSL (and change the Pad Server url back to http:// in Company Configuration ) I can edit pads (using Opera and allowing insecure content). 

Am I missing something in the odoo config? Is there some way to troubleshoot this that I haven't seen?

Update:

I've found the following code in addons/pad.py

if not pad["server"].startswith('http'):
+ pad["server"'http://' + pad["server"]

I tried changing the 'http' to 'https' and running odoo.py --update=all and reinstalling the Collaborative Pads app but am receiving the same error.

Looks like that code is just there to append a http(s): if it's not already there (I tried without http:// in Company Settings --> Pads --> Pad Server to no avail).

Zahin
on 9/6/16, 8:42 AM
0
Cody Unrath
On 9/6/16, 7:04 PM

Thanks to Zahin for reminding me to make sure this wasn't operator error (configuration) and troubleshooting fully before opening a bug report.

I had seen one mention of using reverse proxied SSL for Odoo (8) and Etherpad SSL in a production environment using SSL (https://www.odoo.com/forum/help-1/question/solved-etherpad-in-notes-with-an-ssl-connection-to-odoo-doesnt-load-59730). There wasn't an explicit answer so I poked at it and got my instance to work.

 

In Etherpad's settings.json file the SSL "key" : "/path/to/your.pem", and "cert" : "/path/to/yourchain.pem", I used the SSL keys from Ngnix's /etc/ngnix/sites-available/your-odoo-ssl reverse proxy configuration file (using letsencrypt if it matters). I did have to copy and chown them to a directory that was accessible to etherpad-lite:etherpad-lite (I don't know if that's secure enough for production).  

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 8/23/16, 5:16 PM
Seen: 364 times
Last updated: 9/6/16, 7:12 PM