Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Error: The connectsion refuse? Please help me !!!!

By
thanhthuansteel
on 8/22/16, 11:41 AM 200 views

I am using odoo 9.0c community version that has been installed on a unbuntu 14.04 vps. Today suddentlly i could not logg in to my database web. the browser came out with the warring "The database confused. I have no idea about where the problem from and how to fix this kind of problem. I have tried to logg in the server, when i run the ./openerp-server as well as connect the IP address through the browser then this information came out 


016-08-22 15:28:12,500 3456 ERROR ? werkzeug: Error on request:

Traceback (most recent call last):

File "/usr/local/lib/python2.7/dist-packages/werkzeug/serving.py", line 177, in run_wsgi

execute(self.server.app)

File "/usr/local/lib/python2.7/dist-packages/werkzeug/serving.py", line 165, in execute

application_iter = app(environ, start_response)

File "/opt/odoo/openerp/service/server.py", line 246, in app

return self.app(e, s)

File "/opt/odoo/openerp/service/wsgi_server.py", line 184, in application

return application_unproxied(environ, start_response)

File "/opt/odoo/openerp/service/wsgi_server.py", line 170, in application_unproxied

result = handler(environ, start_response)

File "/opt/odoo/openerp/http.py", line 1493, in __call__

return self.dispatch(environ, start_response)

File "/opt/odoo/openerp/http.py", line 1467, in __call__

return self.app(environ, start_wrapped)

File "/usr/local/lib/python2.7/dist-packages/werkzeug/wsgi.py", line 588, in __call__

return self.app(environ, start_response)

File "/opt/odoo/openerp/http.py", line 1622, in dispatch

self.setup_db(httprequest)

File "/opt/odoo/openerp/http.py", line 1553, in setup_db

httprequest.session.db = db_monodb(httprequest)

File "/opt/odoo/openerp/http.py", line 1700, in db_monodb

dbs = db_list(True, httprequest)

File "/opt/odoo/openerp/http.py", line 1674, in db_list

dbs = openerp.service.db.list_dbs(force)

File "/opt/odoo/openerp/service/db.py", line 323, in list_dbs

with closing(db.cursor()) as cr:

File "/opt/odoo/openerp/sql_db.py", line 630, in cursor

return Cursor(self.__pool, self.dbname, self.dsn, serialized=serialized)

File "/opt/odoo/openerp/sql_db.py", line 164, in __init__

self._cnx = pool.borrow(dsn)

File "/opt/odoo/openerp/sql_db.py", line 513, in _locked

return fun(self, *args, **kwargs)

File "/opt/odoo/openerp/sql_db.py", line 581, in borrow

**connection_info)

File "/usr/local/lib/python2.7/dist-packages/psycopg2/__init__.py", line 164, in connect

conn = _connect(dsn, connection_factory=connection_factory, async=async)

OperationalError: FATAL: role "root" does not exist


Anyone who know how could i make the server run again  please help me. Thank for your time.

0

Ahmed M.Elmubarak

--Ahmed M.Elmubarak--
2988
| 5 3 5
Sudan
--Ahmed M.Elmubarak--


Ahmed M.Elmubarak
On 8/23/16, 2:35 AM

Hi, try to run the server with another user than 'root' 

could you please tell me how to run server with other user ? im new with odoo as well as the programing

thanhthuansteel
on 8/23/16, 2:38 AM

Hi, you can use --db_user to specify the database user, check this link for more options: https://www.odoo.com/documentation/8.0/reference/cmdline.html

Ahmed M.Elmubarak
on 8/24/16, 8:08 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 8/22/16, 11:41 AM
Seen: 200 times
Last updated: 8/23/16, 2:35 AM